# CVE-2025-3248: Langflow Missing Authentication


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 5 May 2025 (CISA KEV), used in ransomware
- **Fix available:** Yes
- **Published:** 7 Apr 2025
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-rvqx-wpfh-mfx7, PYSEC-2025-36, PYSEC-2026-380

## What is CVE-2025-3248?

CVE-2025-3248 is a critical vulnerability in Langflow Langflow, published on 7 Apr 2025. 

### Official description

Langflow versions prior to 1.3.0 are susceptible to code injection in 
the /api/v1/validate/code endpoint. A remote and unauthenticated attacker can send crafted HTTP requests to execute arbitrary
code.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2025-3248?

6 open source packages ship an affected version, including langflow and langflow-base. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langflow` | PyPI | All versions | 1.3.0 |
| `langflow` | PyPI | All versions | 1.3.0 |
| `langflow` | PyPI | All versions | 1.3.0 |
| `langflow-base` | PyPI | All versions | 0.3.0 |
| `langflow-base` | PyPI | All versions | 0.3.0 |
| `langflow-base` | PyPI | All versions | 0.3.0 |

Products: Langflow Langflow.

## How do I fix CVE-2025-3248?

Upgrade langflow to 1.3.0 or later. US federal agencies must fix it by 26 May 2025.

## Is CVE-2025-3248 being exploited?

Yes. Attackers have exploited CVE-2025-3248 in the wild since at least 5 May 2025, including in ransomware campaigns.

Public exploit code:

- CVE-2025-3248 Langflow RCE Exploit (github_poc): https://github.com/ynsmroztas/CVE-2025-3248-Langflow-RCE
- A vulnerability scanner for CVE-2025-3248 in Langflow applications. 用于扫描 Langflow 应用中 CVE-2025-3248 漏洞的工具。 (github_poc): https://github.com/xuemian168/CVE-2025-3248
- https://github.com/verylazytech/CVE-2025-3248 (github_poc): https://github.com/verylazytech/CVE-2025-3248
- Remote Code Execution Exploit for Langflow (CVE-2025-3248) - [ By S4Tech ] (github_poc): https://github.com/0-d3y/langflow-rce-exploit
- https://github.com/hideki233/CVE-2025-3248-Langflow-RCE (github_poc): https://github.com/hideki233/CVE-2025-3248-Langflow-RCE
- POC of CVE-2025-3248, RCE of LangFlow (github_poc): https://github.com/PuddinCat/CVE-2025-3248-POC

## Other vulnerabilities in Langflow Langflow

- [CVE-2026-9198](https://insights.sbomify.com/CVE-2026-9198/): IBM Langflow Code Injection (critical 9.8, exploited in the wild)
- [CVE-2026-0770](https://insights.sbomify.com/CVE-2026-0770/): Langflow Inclusion of Functionality from Untrusted Control Sphere (critical 9.8, exploited in the wild)
- [CVE-2025-34291](https://insights.sbomify.com/CVE-2025-34291/): Langflow Origin Validation Error (critical 9.4, exploited in the wild)
- [CVE-2026-33017](https://insights.sbomify.com/CVE-2026-33017/): Langflow Code Injection (critical 9.3, exploited in the wild)
- [CVE-2026-55255](https://insights.sbomify.com/CVE-2026-55255/): Langflow Authorization Bypass Through User-Controlled Key (high 8.4, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-3248 and fix it if it is affected.

What it is: CVE-2025-3248 is a critical vulnerability in Langflow Langflow, published on 7 Apr 2025. 
Exploitation: Yes. Attackers have exploited CVE-2025-3248 in the wild since at least 5 May 2025, including in ransomware campaigns.

Affected packages and fixed versions:
- langflow (PyPI): affected all versions; fixed in 1.3.0
- langflow (PyPI): affected all versions; fixed in 1.3.0
- langflow (PyPI): affected all versions; fixed in 1.3.0
- langflow-base (PyPI): affected all versions; fixed in 0.3.0
- langflow-base (PyPI): affected all versions; fixed in 0.3.0
- langflow-base (PyPI): affected all versions; fixed in 0.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-3248/ (Markdown: https://insights.sbomify.com/CVE-2025-3248/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-3248
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-3248
- OSV: https://osv.dev/vulnerability/CVE-2025-3248

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-3248/
Summaries are generated and may contain mistakes; the official description above is the record.
