{"answers":{"affected":"1 open source package ship an affected version, including mediawiki.","exploited":"There is no known exploitation of CVE-2025-32698 in the wild and no public exploit code.","fix":"Upgrade mediawiki to a fixed version for your release line: 1.41.1 or 1.43.1.","what":"CVE-2025-32698 is a low-severity vulnerability in Wikimedia Foundation MediaWiki, published on 10 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-32698 and fix it if it is affected.\n\nWhat it is: CVE-2025-32698 is a low-severity vulnerability in Wikimedia Foundation MediaWiki, published on 10 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-32698 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mediawiki (Bitnami): affected all versions; fixed in 1.41.1, 1.43.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-32698/ (Markdown: https://insights.sbomify.com/CVE-2025-32698/index.md)","id":"CVE-2025-32698","markdown":"https://insights.sbomify.com/CVE-2025-32698/index.md","name":"CVE-2025-32698","record":{"aliases":["BIT-mediawiki-2025-32698","DEBIAN-CVE-2025-32698","GHSA-hh2q-7x5p-j2g2","UBUNTU-CVE-2025-32698"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"MediaWiki","requires_auth":"none","summary":"Attackers can view suppressed log entries due to incorrect enforcement of suppression restrictions in MediaWiki's LogPager component.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"wikimedia-foundation","cpe":[],"cvss":{"score":2.1,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/RE:M/U:Green","version":"4.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/logging/LogPager.Php.\n\nThis issue affects MediaWiki: before 1.39.12, 1.42.6, 1.43.1.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"LogPager.php: Restriction enforcer functions do not correctly enforce suppression restrictions","id":"CVE-2025-32698","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"information_disclosure","year":"2025"},"n_packages":1,"n_references":1,"next":{"headline":"Potential javascript injection attack enabled by Unicode normalization in Action API","id":"CVE-2025-32699"},"packages":[{"ecosystem":"Bitnami","fixed":["1.41.1","1.43.1"],"introduced":["0","1.42.0"],"last_affected":[],"package":"mediawiki","purl":"pkg:bitnami/mediawiki","source":"BIT-mediawiki-2025-32698"}],"prev":{"headline":"Cascading protection is not preventing file reversions","id":"CVE-2025-32697"},"products":["MediaWiki"],"published":"2025-04-10","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["Wikimedia Foundation"]},"summary":"Attackers can view suppressed log entries due to incorrect enforcement of suppression restrictions in MediaWiki's LogPager component.","url":"https://insights.sbomify.com/CVE-2025-32698/"}