# CVE-2025-32698: LogPager.php: Restriction enforcer functions do not correctly enforce suppression restrictions

> Attackers can view suppressed log entries due to incorrect enforcement of suppression restrictions in MediaWiki's LogPager component.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/RE:M/U:Green`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Apr 2025
- **Updated:** 3 Nov 2025
- **Also known as:** BIT-mediawiki-2025-32698, DEBIAN-CVE-2025-32698, GHSA-hh2q-7x5p-j2g2, UBUNTU-CVE-2025-32698

## What is CVE-2025-32698?

CVE-2025-32698 is a low-severity vulnerability in Wikimedia Foundation MediaWiki, published on 10 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/logging/LogPager.Php.

This issue affects MediaWiki: before 1.39.12, 1.42.6, 1.43.1.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-32698?

1 open source package ship an affected version, including mediawiki.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki` | Bitnami | All versions | 1.41.1, 1.43.1 |

## How do I fix CVE-2025-32698?

Upgrade mediawiki to a fixed version for your release line: 1.41.1 or 1.43.1.

## Is CVE-2025-32698 being exploited?

There is no known exploitation of CVE-2025-32698 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32698 and fix it if it is affected.

What it is: CVE-2025-32698 is a low-severity vulnerability in Wikimedia Foundation MediaWiki, published on 10 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-32698 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki (Bitnami): affected all versions; fixed in 1.41.1, 1.43.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32698/ (Markdown: https://insights.sbomify.com/CVE-2025-32698/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32698
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32698
- OSV: https://osv.dev/vulnerability/CVE-2025-32698

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32698/
Summaries are generated and may contain mistakes; the official description above is the record.
