CVE-2025-32699 Potential javascript injection attack enabled by Unicode normalization in Action API
Attackers can inject JavaScript via Unicode normalization in the Action API, potentially leading to code execution or account takeover.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-32699?
CVE-2025-32699 is a low-severity cross-site scripting vulnerability in Wikimedia Foundation MediaWiki, published on 10 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Vulnerability in Wikimedia Foundation MediaWiki, Wikimedia Foundation Parsoid.This issue affects MediaWiki: before 1.39.12, 1.42.6, 1.43.1; Parsoid: before 0.16.5, 0.19.2, 0.20.2.
Which versions are affected by CVE-2025-32699?
1 open source package ship an affected version, including mediawiki.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki Bitnami | All versions | 1.41.1, 1.43.1 |
How do I fix CVE-2025-32699?
Upgrade mediawiki to a fixed version for your release line: 1.41.1 or 1.43.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-32699 being exploited?
There is no known exploitation of CVE-2025-32699 in the wild and no public exploit code.
Sources
Also known as BIT-mediawiki-2025-32699, DEBIAN-CVE-2025-32699, GHSA-pq7c-cvqp-fq9x, UBUNTU-CVE-2025-32699.