CVE-2025-32777 Volcano Scheduler Denial of Service via Unbounded Response from Elastic Service/extender Plugin
Compromised Elastic or extender plugins can crash the Volcano scheduler via unbounded responses, causing denial of service and privilege escalation across node boundaries.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-32777?
CVE-2025-32777 is a high-severity denial of service vulnerability in volcano-sh volcano, published on 30 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Volcano is a Kubernetes-native batch scheduling system. Prior to versions 1.11.2, 1.10.2, 1.9.1, 1.11.0-network-topology-preview.3, and 1.12.0-alpha.2, attacker compromise of either the Elastic service or the extender plugin can cause denial of service of the scheduler. This is a privilege escalation, because Volcano users may run their Elastic service and extender plugins in separate pods or nodes from the scheduler. In the Kubernetes security model, node isolation is a security boundary, and as such an attacker is able to cross that boundary in Volcano's case if they have compromised either the vulnerable services or the pod/node in which they are deployed. The scheduler will become unavailable to other users and workloads in the cluster. The scheduler will either crash with an unrecoverable OOM panic or freeze while consuming excessive amounts of memory. This issue has been patched in versions 1.11.2, 1.10.2, 1.9.1, 1.11.0-network-topology-preview.3, and 1.12.0-alpha.2.
Weakness: CWE-770
Which versions are affected by CVE-2025-32777?
11 open source packages ship an affected version, including volcano.sh/volcano.
| Package | Affected | Fixed in |
|---|---|---|
volcano.sh/volcano Go | All versions | 1.9.1, 1.10.2, 1.11.0-network-topology-preview.3, 1.11.2, 1.12.0-alpha.2 |
volcano.sh/volcano Go | All versions | 1.9.1 |
volcano.sh/volcano Go | All versions | 1.9.1 |
volcano.sh/volcano Go | From 1.10.0-alpha.0 | 1.10.2 |
volcano.sh/volcano Go | From 1.10.0-alpha.0 | 1.10.2 |
volcano.sh/volcano Go | From 1.11.0 | 1.11.2 |
5 more packages
volcano.sh/volcano Go | From 1.11.0 | 1.11.2 |
volcano.sh/volcano Go | From 1.11.0-network-topology-preview.0 | 1.11.0-network-topology-preview.3 |
volcano.sh/volcano Go | From 1.11.0-network-topology-preview.0 | 1.11.0-network-topology-preview.3 |
volcano.sh/volcano Go | From 1.12.0-alpha.0 | 1.12.0-alpha.2 |
volcano.sh/volcano Go | From 1.12.0-alpha.0 | 1.12.0-alpha.2 |
How do I fix CVE-2025-32777?
Upgrade volcano.sh/volcano to a fixed version for your release line: 1.9.1, 1.10.2, 1.11.0-network-topology-preview.3 or 1.11.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-32777 being exploited?
There is no known exploitation of CVE-2025-32777 in the wild and no public exploit code.
Sources
Also known as GHSA-hg79-fw4p-25p8, GO-2025-3656.