# CVE-2025-32777: Volcano Scheduler Denial of Service via Unbounded Response from Elastic Service/extender Plugin

> Compromised Elastic or extender plugins can crash the Volcano scheduler via unbounded responses, causing denial of service and privilege escalation across node boundaries.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Apr 2025
- **Updated:** 1 May 2025
- **Also known as:** GHSA-hg79-fw4p-25p8, GO-2025-3656

## What is CVE-2025-32777?

CVE-2025-32777 is a high-severity denial of service vulnerability in volcano-sh volcano, published on 30 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Volcano is a Kubernetes-native batch scheduling system. Prior to versions 1.11.2, 1.10.2, 1.9.1, 1.11.0-network-topology-preview.3, and 1.12.0-alpha.2, attacker compromise of either the Elastic service or the extender plugin can cause denial of service of the scheduler. This is a privilege escalation, because Volcano users may run their Elastic service and extender plugins in separate pods or nodes from the scheduler. In the Kubernetes security model, node isolation is a security boundary, and as such an attacker is able to cross that boundary in Volcano's case if they have compromised either the vulnerable services or the pod/node in which they are deployed. The scheduler will become unavailable to other users and workloads in the cluster. The scheduler will either crash with an unrecoverable OOM panic or freeze while consuming excessive amounts of memory. This issue has been patched in versions 1.11.2, 1.10.2, 1.9.1, 1.11.0-network-topology-preview.3, and 1.12.0-alpha.2.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-32777?

11 open source packages ship an affected version, including volcano.sh/volcano.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `volcano.sh/volcano` | Go | All versions | 1.9.1, 1.10.2, 1.11.0-network-topology-preview.3, 1.11.2, 1.12.0-alpha.2 |
| `volcano.sh/volcano` | Go | All versions | 1.9.1 |
| `volcano.sh/volcano` | Go | All versions | 1.9.1 |
| `volcano.sh/volcano` | Go | From 1.10.0-alpha.0 | 1.10.2 |
| `volcano.sh/volcano` | Go | From 1.10.0-alpha.0 | 1.10.2 |
| `volcano.sh/volcano` | Go | From 1.11.0 | 1.11.2 |
| `volcano.sh/volcano` | Go | From 1.11.0 | 1.11.2 |
| `volcano.sh/volcano` | Go | From 1.11.0-network-topology-preview.0 | 1.11.0-network-topology-preview.3 |
| `volcano.sh/volcano` | Go | From 1.11.0-network-topology-preview.0 | 1.11.0-network-topology-preview.3 |
| `volcano.sh/volcano` | Go | From 1.12.0-alpha.0 | 1.12.0-alpha.2 |
| `volcano.sh/volcano` | Go | From 1.12.0-alpha.0 | 1.12.0-alpha.2 |

## How do I fix CVE-2025-32777?

Upgrade volcano.sh/volcano to a fixed version for your release line: 1.9.1, 1.10.2, 1.11.0-network-topology-preview.3 or 1.11.2.

## Is CVE-2025-32777 being exploited?

There is no known exploitation of CVE-2025-32777 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32777 and fix it if it is affected.

What it is: CVE-2025-32777 is a high-severity denial of service vulnerability in volcano-sh volcano, published on 30 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-32777 in the wild and no public exploit code.

Affected packages and fixed versions:
- volcano.sh/volcano (Go): affected all versions; fixed in 1.9.1, 1.10.2, 1.11.0-network-topology-preview.3, 1.11.2, 1.12.0-alpha.2
- volcano.sh/volcano (Go): affected all versions; fixed in 1.9.1
- volcano.sh/volcano (Go): affected all versions; fixed in 1.9.1
- volcano.sh/volcano (Go): affected from 1.10.0-alpha.0; fixed in 1.10.2
- volcano.sh/volcano (Go): affected from 1.10.0-alpha.0; fixed in 1.10.2
- volcano.sh/volcano (Go): affected from 1.11.0; fixed in 1.11.2
- volcano.sh/volcano (Go): affected from 1.11.0; fixed in 1.11.2
- volcano.sh/volcano (Go): affected from 1.11.0-network-topology-preview.0; fixed in 1.11.0-network-topology-preview.3
- volcano.sh/volcano (Go): affected from 1.11.0-network-topology-preview.0; fixed in 1.11.0-network-topology-preview.3
- volcano.sh/volcano (Go): affected from 1.12.0-alpha.0; fixed in 1.12.0-alpha.2
- volcano.sh/volcano (Go): affected from 1.12.0-alpha.0; fixed in 1.12.0-alpha.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32777/ (Markdown: https://insights.sbomify.com/CVE-2025-32777/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32777
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32777
- OSV: https://osv.dev/vulnerability/CVE-2025-32777

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32777/
Summaries are generated and may contain mistakes; the official description above is the record.
