# CVE-2025-32779: labsai/eddi Vulnerable to Path Traversal (Zip Slip) in ZIP Import Function

> An attacker can exploit a Zip Slip vulnerability in the backup import endpoint to overwrite application files, potentially leading to remote code execution.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Apr 2025
- **Updated:** 27 Oct 2025
- **Also known as:** GHSA-9v34-frgq-63mv

## What is CVE-2025-32779?

CVE-2025-32779 is a medium-severity path traversal vulnerability in labsai EDDI, published on 15 Apr 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

E.D.D.I (Enhanced Dialog Driven Interface) is a middleware to connect and manage LLM API bots. In versions before 5.5.0, an attacker with access to the `/backup/import` API endpoint can write arbitrary files to locations outside the intended extraction directory due to a Zip Slip vulnerability. Although the application runs as a non-root user (`185`), limiting direct impact on system-level files, this vulnerability can still be exploited to overwrite application files (e.g., JAR libraries) owned by the application user. This overwrite can potentially lead to Remote Code Execution (RCE) within the application's context. This issue has been patched in version 5.5.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-32779?


## How do I fix CVE-2025-32779?

No fix has been published for CVE-2025-32779 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-32779 being exploited?

There is no known exploitation of CVE-2025-32779 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32779 and fix it if it is affected.

What it is: CVE-2025-32779 is a medium-severity path traversal vulnerability in labsai EDDI, published on 15 Apr 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-32779 in the wild and no public exploit code.

Affected product: labsai EDDI. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32779/ (Markdown: https://insights.sbomify.com/CVE-2025-32779/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32779
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32779
- OSV: https://osv.dev/vulnerability/CVE-2025-32779

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32779/
Summaries are generated and may contain mistakes; the official description above is the record.
