# CVE-2025-32781: Apollo: Apollo Portal release endpoint allows cross-application configuration disclosure via releaseId

> Low-privileged users can read configuration data from other applications by guessing release IDs when member-only view is enabled.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Jul 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-jxpj-9j24-w337

## What is CVE-2025-32781?

CVE-2025-32781 is a medium-severity missing authorization vulnerability in apolloconfig apollo, published on 15 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apollo is a reliable configuration management system suitable for microservice configuration management scenarios. Prior to 2.5.0, Apollo Portal does not verify application and namespace permissions when an authenticated user requests a release by ID through GET /envs/{env}/releases/{releaseId} while configView.memberOnly.envs is enabled, allowing a low-privileged Portal user who obtains or guesses a valid releaseId to read configuration data from other applications and namespaces without calling UserPermissionValidator.shouldHideConfigToCurrentUser(...). This issue is fixed in version 2.5.0.

Weakness: CWE-862 (Missing Authorization), CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2025-32781?

2 open source packages ship an affected version, including com.ctrip.framework.apollo:apollo.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.ctrip.framework.apollo:apollo` | Maven | All versions | None |
| `com.ctrip.framework.apollo:apollo` | Maven | All versions | None |

## How do I fix CVE-2025-32781?

No fix has been published for CVE-2025-32781 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-32781 being exploited?

There is no known exploitation of CVE-2025-32781 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32781 and fix it if it is affected.

What it is: CVE-2025-32781 is a medium-severity missing authorization vulnerability in apolloconfig apollo, published on 15 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-32781 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.ctrip.framework.apollo:apollo (Maven): affected all versions; no fix listed
- com.ctrip.framework.apollo:apollo (Maven): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32781/ (Markdown: https://insights.sbomify.com/CVE-2025-32781/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32781
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32781
- OSV: https://osv.dev/vulnerability/CVE-2025-32781

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32781/
Summaries are generated and may contain mistakes; the official description above is the record.
