# CVE-2025-32782: Ash Authentication email link auto-click account confirmation vulnerability

> Attackers can register accounts using victim emails that are auto-confirmed by email clients, bypassing manual verification steps.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2025
- **Updated:** 16 Apr 2025
- **Also known as:** GHSA-3988-q8q7-p787

## What is CVE-2025-32782?

CVE-2025-32782 is a medium-severity vulnerability in team-alembic ash_authentication, published on 15 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Ash Authentication provides authentication for the Ash framework. The confirmation flow for account creation currently uses a GET request triggered by clicking a link sent via email. Some email clients and security tools (e.g., Outlook, virus scanners, and email previewers) may automatically follow these links, unintentionally confirming the account. This allows an attacker to register an account using another user’s email and potentially have it auto-confirmed by the victim’s email client. This does not allow attackers to take over or access existing accounts or private data. It is limited to account confirmation of new accounts only. This vulnerability is fixed in 4.7.0.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2025-32782?

2 open source packages ship an affected version, including ash_authentication.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ash_authentication` | Hex | All versions | 4.7.0 |
| `ash_authentication` | Hex | All versions | 4.7.0 |

## How do I fix CVE-2025-32782?

Upgrade ash_authentication to 4.7.0 or later.

## Is CVE-2025-32782 being exploited?

There is no known exploitation of CVE-2025-32782 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32782 and fix it if it is affected.

What it is: CVE-2025-32782 is a medium-severity vulnerability in team-alembic ash_authentication, published on 15 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-32782 in the wild and no public exploit code.

Affected packages and fixed versions:
- ash_authentication (Hex): affected all versions; fixed in 4.7.0
- ash_authentication (Hex): affected all versions; fixed in 4.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32782/ (Markdown: https://insights.sbomify.com/CVE-2025-32782/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32782
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32782
- OSV: https://osv.dev/vulnerability/CVE-2025-32782

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32782/
Summaries are generated and may contain mistakes; the official description above is the record.
