# CVE-2025-32785: Pi-hole Admin Interface vulnerable to persistent XSS on Subscribed lists group management (Adress Field)

> An authenticated user can inject malicious JavaScript into the Address field, which executes when another user updates the gravity database.

- **Severity:** Low 2.0 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 27 Oct 2025
- **Updated:** 27 Oct 2025
- **Also known as:** GHSA-7w6h-3gwc-qhq5

## What is CVE-2025-32785?

CVE-2025-32785 is a low-severity cross-site scripting vulnerability in pi-hole web, published on 27 Oct 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Pi-hole Admin Interface is a web interface for managing Pi-hole, a network-level advertisement and internet tracker blocking application. Pi-hole Admin Interface versions prior to 6.3 are vulnerable to cross-site scripting (XSS) via the Address field in the Subscribed Lists group management section. An authenticated user can inject malicious JavaScript by adding a payload to the Address field when creating or editing a list entry. The vulnerability is triggered when another user navigates to the Tools section and performs a gravity database update. The Address field does not properly sanitize input, allowing special characters and script tags to bypass validation. This has been patched in version 6.3.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-32785?

It affects 1 product.


Products: Pi-Hole Web Interface.

## How do I fix CVE-2025-32785?

No fix has been published for CVE-2025-32785 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-32785 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32785 exists.

## Other vulnerabilities in pi-hole web

- [CVE-2026-33765](https://insights.sbomify.com/CVE-2026-33765/): Pi-hole Web Interface has a Command Injection Vulnerability (high 8.9)
- [CVE-2023-23614](https://insights.sbomify.com/CVE-2023-23614/): Improper session handling of "Remember me for 7 days" functionality (high 8.8)
- [CVE-2025-59151](https://insights.sbomify.com/CVE-2025-59151/): Pi-hole Admin Interface vulnerable to HTTP response header injection via CRLF injection (high 8.2)
- [CVE-2021-3706](https://insights.sbomify.com/CVE-2021-3706/): Sensitive Cookie Without 'HttpOnly' Flag in pi-hole/adminlte (high 7.4)
- [CVE-2021-41175](https://insights.sbomify.com/CVE-2021-41175/): Stored XSS in Client Groups Management (Authenticated) (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32785 and fix it if it is affected.

What it is: CVE-2025-32785 is a low-severity cross-site scripting vulnerability in pi-hole web, published on 27 Oct 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32785 exists.

Affected product: pi-hole web. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32785/ (Markdown: https://insights.sbomify.com/CVE-2025-32785/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32785
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32785
- OSV: https://osv.dev/vulnerability/CVE-2025-32785

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32785/
Summaries are generated and may contain mistakes; the official description above is the record.
