CVE-2025-32786 GLPI Inventory Plugin is Vulnerable to Unauthenticated SQL Injection

High 7.5 Published Updated

Unauthenticated attackers can execute arbitrary SQL commands via the GLPI Inventory Plugin, potentially reading or modifying database contents.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-32786?

CVE-2025-32786 is a high-severity SQL injection vulnerability in glpi-project glpi-inventory-plugin, published on 4 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The GLPI Inventory Plugin handles network discovery, inventory, software deployment, and data collection for GLPI agents. Versions 1.5.0 and below are vulnerable to SQL Injection. This issue is fixed in version 1.5.1.

Weakness: CWE-89

Which versions are affected by CVE-2025-32786?

How do I fix CVE-2025-32786?

No fix has been published for CVE-2025-32786 yet. Limit exposure of the affected software until one is available.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2025-32786 being exploited?

There is no known exploitation of CVE-2025-32786 in the wild and no public exploit code.

Sources

Also known as GHSA-w2cp-r675-6xpq.

Is CVE-2025-32786 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free