{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-32786 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-32786 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-32786 is a high-severity SQL injection vulnerability in glpi-project glpi-inventory-plugin, published on 4 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-32786 and fix it if it is affected.\n\nWhat it is: CVE-2025-32786 is a high-severity SQL injection vulnerability in glpi-project glpi-inventory-plugin, published on 4 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-32786 in the wild and no public exploit code.\n\nAffected product: glpi-project glpi-inventory-plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-32786/ (Markdown: https://insights.sbomify.com/CVE-2025-32786/index.md)","id":"CVE-2025-32786","markdown":"https://insights.sbomify.com/CVE-2025-32786/index.md","name":"CVE-2025-32786","record":{"aliases":["GHSA-w2cp-r675-6xpq"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"GLPI Inventory Plugin","requires_auth":"none","summary":"Unauthenticated attackers can execute arbitrary SQL commands via the GLPI Inventory Plugin, potentially reading or modifying database contents.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"The GLPI Inventory Plugin handles network discovery, inventory, software deployment, and data collection for GLPI agents. Versions 1.5.0 and below are vulnerable to SQL Injection. This issue is fixed in version 1.5.1.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"GLPI Inventory Plugin is Vulnerable to Unauthenticated SQL Injection","id":"CVE-2025-32786","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"sql_injection","year":"2025"},"n_packages":0,"n_references":3,"next":{"headline":"SoftEtherVPN Affected by NULL dereference in DeleteIPv6DefaultRouterInRA","id":"CVE-2025-32787"},"packages":[],"prev":{"headline":"Pi-hole Admin Interface vulnerable to persistent XSS on Subscribed lists group management (Adress Field)","id":"CVE-2025-32785"},"products":["glpi-inventory-plugin"],"published":"2025-11-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-05","vendors":["glpi-project"]},"summary":"Unauthenticated attackers can execute arbitrary SQL commands via the GLPI Inventory Plugin, potentially reading or modifying database contents.","url":"https://insights.sbomify.com/CVE-2025-32786/"}