# CVE-2025-32786: GLPI Inventory Plugin is Vulnerable to Unauthenticated SQL Injection

> Unauthenticated attackers can execute arbitrary SQL commands via the GLPI Inventory Plugin, potentially reading or modifying database contents.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 4 Nov 2025
- **Updated:** 5 Nov 2025
- **Also known as:** GHSA-w2cp-r675-6xpq

## What is CVE-2025-32786?

CVE-2025-32786 is a high-severity SQL injection vulnerability in glpi-project glpi-inventory-plugin, published on 4 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The GLPI Inventory Plugin handles network discovery, inventory, software deployment, and data collection for GLPI agents. Versions 1.5.0 and below are vulnerable to SQL Injection. This issue is fixed in version 1.5.1.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-32786?


## How do I fix CVE-2025-32786?

No fix has been published for CVE-2025-32786 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-32786 being exploited?

There is no known exploitation of CVE-2025-32786 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32786 and fix it if it is affected.

What it is: CVE-2025-32786 is a high-severity SQL injection vulnerability in glpi-project glpi-inventory-plugin, published on 4 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-32786 in the wild and no public exploit code.

Affected product: glpi-project glpi-inventory-plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32786/ (Markdown: https://insights.sbomify.com/CVE-2025-32786/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32786
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32786
- OSV: https://osv.dev/vulnerability/CVE-2025-32786

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32786/
Summaries are generated and may contain mistakes; the official description above is the record.
