# CVE-2025-32788: OctoPrint Authenticated Reverse Proxy Page Authentication Bypass

> Attackers can bypass login redirects to access frontend HTML, potentially exposing sensitive data or enabling future authentication flaws.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Apr 2025
- **Updated:** 25 Apr 2025
- **Also known as:** GHSA-qw93-h6pf-226x, PYSEC-2025-56

## What is CVE-2025-32788?

CVE-2025-32788 is a medium-severity authentication bypass vulnerability in OctoPrint, published on 22 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

OctoPrint provides a web interface for controlling consumer 3D printers. In versions up to and including 1.10.3, OctoPrint has a vulnerability that allows an attacker to bypass the login redirect and directly access the rendered HTML of certain frontend pages. The primary risk lies in potential future modifications to the codebase that might incorrectly rely on the vulnerable internal functions for authentication checks, leading to security vulnerabilities. This issue has been patched in version 1.11.0.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2025-32788?

3 open source packages ship an affected version, including octoprint and OctoPrint. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `octoprint` | PyPI | All versions | 1.11.0 |
| `octoprint` | PyPI | All versions | 1.11.0 |
| `OctoPrint` | PyPI | All versions | 1.11.0 |

Products: Octoprint Octoprint.

## How do I fix CVE-2025-32788?

Upgrade octoprint to 1.11.0 or later.

## Is CVE-2025-32788 being exploited?

There is no known exploitation of CVE-2025-32788 in the wild and no public exploit code.

## Other vulnerabilities in OctoPrint

- [CVE-2018-16710](https://insights.sbomify.com/CVE-2018-16710/): Information disclosure in n/a (critical 9.1)
- [CVE-2025-58180](https://insights.sbomify.com/CVE-2025-58180/): OctoPrint is Vulnerable to RCE Attacks via Unsanitized Filename in File Upload (high 7.5)
- [CVE-2022-1430](https://insights.sbomify.com/CVE-2022-1430/): Cross-site Scripting (XSS) - DOM in octoprint/octoprint (high 7.5)
- [CVE-2022-1432](https://insights.sbomify.com/CVE-2022-1432/): Cross-site Scripting (XSS) - Generic in octoprint/octoprint (high 7.5)
- [CVE-2024-32977](https://insights.sbomify.com/CVE-2024-32977/): OctoPrint Authentication Bypass via X-Forwarded-For Header when autologinLocal is enabled (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32788 and fix it if it is affected.

What it is: CVE-2025-32788 is a medium-severity authentication bypass vulnerability in OctoPrint, published on 22 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-32788 in the wild and no public exploit code.

Affected packages and fixed versions:
- octoprint (PyPI): affected all versions; fixed in 1.11.0
- octoprint (PyPI): affected all versions; fixed in 1.11.0
- OctoPrint (PyPI): affected all versions; fixed in 1.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32788/ (Markdown: https://insights.sbomify.com/CVE-2025-32788/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32788
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32788
- OSV: https://osv.dev/vulnerability/CVE-2025-32788

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32788/
Summaries are generated and may contain mistakes; the official description above is the record.
