{"answers":{"affected":"2 open source packages ship an affected version, including @backstage/plugin-permission-backend.","exploited":"There is no known exploitation of CVE-2025-32791 in the wild and no public exploit code.","fix":"Upgrade @backstage/plugin-permission-backend to 0.6.0 or later.","what":"CVE-2025-32791 is a medium-severity vulnerability in backstage, published on 16 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-32791 and fix it if it is affected.\n\nWhat it is: CVE-2025-32791 is a medium-severity vulnerability in backstage, published on 16 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-32791 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @backstage/plugin-permission-backend (npm): affected all versions; fixed in 0.6.0\n- @backstage/plugin-permission-backend (npm): affected all versions; fixed in 0.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-32791/ (Markdown: https://insights.sbomify.com/CVE-2025-32791/index.md)","id":"CVE-2025-32791","markdown":"https://insights.sbomify.com/CVE-2025-32791/index.md","name":"CVE-2025-32791","record":{"aliases":["GHSA-f8j4-p5cr-p777"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Backstage permission plugin","requires_auth":"low_privilege","summary":"Attackers can leak conditional decision details from the Backstage permission backend if conditional policies are active, exposing sensitive logic.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-213","name":"Exposure of Sensitive Information Due to Incompatible Policies"}],"description":"The Backstage Scaffolder plugin houses types and utilities for building scaffolder-related modules. A vulnerability in the Backstage permission plugin backend allows callers to extract some information about the conditional decisions returned by the permission policy installed in the permission backend. If the permission system is not in use or if the installed permission policy does not use conditional decisions, there is no impact. This issue has been patched in version 0.6.0 of the permissions backend. A workaround includes having administrators of the permission policies ensure that they are crafted in such a way that conditional decisions do not contain any sensitive information.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Permission policy information leakage in Backstage permission system","id":"CVE-2025-32791","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"ses's global contour bindings leak into Compartment lexical scope","id":"CVE-2025-32792"},"packages":[{"ecosystem":"npm","fixed":["0.6.0"],"introduced":["0"],"last_affected":[],"package":"@backstage/plugin-permission-backend","purl":null,"source":"GHSA-f8j4-p5cr-p777"},{"ecosystem":"npm","fixed":["0.6.0"],"introduced":["0"],"last_affected":[],"package":"@backstage/plugin-permission-backend","purl":"pkg:npm/%40backstage/plugin-permission-backend","source":"GHSA-f8j4-p5cr-p777"}],"prev":{"headline":"Dify Allows Insecure User Role Access Control for APP DSL Exporting","id":"CVE-2025-32790"},"products":["backstage"],"published":"2025-04-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-17","vendors":["backstage"]},"summary":"Attackers can leak conditional decision details from the Backstage permission backend if conditional policies are active, exposing sensitive logic.","url":"https://insights.sbomify.com/CVE-2025-32791/"}