# CVE-2025-32791: Permission policy information leakage in Backstage permission system

> Attackers can leak conditional decision details from the Backstage permission backend if conditional policies are active, exposing sensitive logic.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Apr 2025
- **Updated:** 17 Apr 2025
- **Also known as:** GHSA-f8j4-p5cr-p777

## What is CVE-2025-32791?

CVE-2025-32791 is a medium-severity vulnerability in backstage, published on 16 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Backstage Scaffolder plugin houses types and utilities for building scaffolder-related modules. A vulnerability in the Backstage permission plugin backend allows callers to extract some information about the conditional decisions returned by the permission policy installed in the permission backend. If the permission system is not in use or if the installed permission policy does not use conditional decisions, there is no impact. This issue has been patched in version 0.6.0 of the permissions backend. A workaround includes having administrators of the permission policies ensure that they are crafted in such a way that conditional decisions do not contain any sensitive information.

Weakness: CWE-213 (Exposure of Sensitive Information Due to Incompatible Policies)

## Which versions are affected by CVE-2025-32791?

2 open source packages ship an affected version, including @backstage/plugin-permission-backend.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/plugin-permission-backend` | npm | All versions | 0.6.0 |
| `@backstage/plugin-permission-backend` | npm | All versions | 0.6.0 |

## How do I fix CVE-2025-32791?

Upgrade @backstage/plugin-permission-backend to 0.6.0 or later.

## Is CVE-2025-32791 being exploited?

There is no known exploitation of CVE-2025-32791 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32791 and fix it if it is affected.

What it is: CVE-2025-32791 is a medium-severity vulnerability in backstage, published on 16 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-32791 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/plugin-permission-backend (npm): affected all versions; fixed in 0.6.0
- @backstage/plugin-permission-backend (npm): affected all versions; fixed in 0.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32791/ (Markdown: https://insights.sbomify.com/CVE-2025-32791/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32791
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32791
- OSV: https://osv.dev/vulnerability/CVE-2025-32791

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32791/
Summaries are generated and may contain mistakes; the official description above is the record.
