{"answers":{"affected":"2 open source packages ship an affected version, including ses.","exploited":"There is no known exploitation of CVE-2025-32792 in the wild and no public exploit code.","fix":"Upgrade ses to 1.12.0 or later.","what":"CVE-2025-32792 is a high-severity vulnerability in endojs endo, published on 18 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-32792 and fix it if it is affected.\n\nWhat it is: CVE-2025-32792 is a high-severity vulnerability in endojs endo, published on 18 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-32792 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ses (npm): affected all versions; fixed in 1.12.0\n- ses (npm): affected all versions; fixed in 1.12.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-32792/ (Markdown: https://insights.sbomify.com/CVE-2025-32792/index.md)","id":"CVE-2025-32792","markdown":"https://insights.sbomify.com/CVE-2025-32792/index.md","name":"CVE-2025-32792","record":{"aliases":["GHSA-h9w6-f932-gq62"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript sandbox library","requires_auth":"none","summary":"The ses library leaks top-level lexical bindings into third-party code compartments, allowing attackers to read sensitive variables.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-497","name":"Exposure of Sensitive System Information to an Unauthorized Control Sphere"}],"description":"SES safely executes third-party JavaScript 'strict' mode programs in compartments that have no excess authority in their global scope. Prior to version 1.12.0, web pages and web extensions using `ses` and the Compartment API to evaluate third-party code in an isolated execution environment that have also elsewhere used `const`, `let`, and `class` bindings in the top-level scope of a `\u003cscript\u003e` tag will have inadvertently revealed these bindings in the lexical scope of third-party code. This issue has been patched in version 1.12.0. Workarounds for this issue involve either avoiding top-level `let`, `const`, or `class` bindings in `\u003cscript\u003e` tags, or change these to `var` bindings to be reflected on `globalThis`.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ses's global contour bindings leak into Compartment lexical scope","id":"CVE-2025-32792","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"Cilium packets from terminating endpoints may not be encrypted in Wireguard-enabled clusters","id":"CVE-2025-32793"},"packages":[{"ecosystem":"npm","fixed":["1.12.0"],"introduced":["0"],"last_affected":[],"package":"ses","purl":null,"source":"GHSA-h9w6-f932-gq62"},{"ecosystem":"npm","fixed":["1.12.0"],"introduced":["0"],"last_affected":[],"package":"ses","purl":"pkg:npm/ses","source":"GHSA-h9w6-f932-gq62"}],"prev":{"headline":"Permission policy information leakage in Backstage permission system","id":"CVE-2025-32791"},"products":["endo"],"published":"2025-04-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-21","vendors":["endojs"]},"summary":"The ses library leaks top-level lexical bindings into third-party code compartments, allowing attackers to read sensitive variables.","url":"https://insights.sbomify.com/CVE-2025-32792/"}