# CVE-2025-32792: ses's global contour bindings leak into Compartment lexical scope

> The ses library leaks top-level lexical bindings into third-party code compartments, allowing attackers to read sensitive variables.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Apr 2025
- **Updated:** 21 Apr 2025
- **Also known as:** GHSA-h9w6-f932-gq62

## What is CVE-2025-32792?

CVE-2025-32792 is a high-severity vulnerability in endojs endo, published on 18 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SES safely executes third-party JavaScript 'strict' mode programs in compartments that have no excess authority in their global scope. Prior to version 1.12.0, web pages and web extensions using `ses` and the Compartment API to evaluate third-party code in an isolated execution environment that have also elsewhere used `const`, `let`, and `class` bindings in the top-level scope of a `<script>` tag will have inadvertently revealed these bindings in the lexical scope of third-party code. This issue has been patched in version 1.12.0. Workarounds for this issue involve either avoiding top-level `let`, `const`, or `class` bindings in `<script>` tags, or change these to `var` bindings to be reflected on `globalThis`.

Weakness: CWE-497 (Exposure of Sensitive System Information to an Unauthorized Control Sphere)

## Which versions are affected by CVE-2025-32792?

2 open source packages ship an affected version, including ses.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ses` | npm | All versions | 1.12.0 |
| `ses` | npm | All versions | 1.12.0 |

## How do I fix CVE-2025-32792?

Upgrade ses to 1.12.0 or later.

## Is CVE-2025-32792 being exploited?

There is no known exploitation of CVE-2025-32792 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32792 and fix it if it is affected.

What it is: CVE-2025-32792 is a high-severity vulnerability in endojs endo, published on 18 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-32792 in the wild and no public exploit code.

Affected packages and fixed versions:
- ses (npm): affected all versions; fixed in 1.12.0
- ses (npm): affected all versions; fixed in 1.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32792/ (Markdown: https://insights.sbomify.com/CVE-2025-32792/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32792
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32792
- OSV: https://osv.dev/vulnerability/CVE-2025-32792

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32792/
Summaries are generated and may contain mistakes; the official description above is the record.
