{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32796 exists.","fix":"No fix has been published for CVE-2025-32796 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-32796 is a medium-severity missing authorization vulnerability in langgenius dify, published on 18 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-32796 and fix it if it is affected.\n\nWhat it is: CVE-2025-32796 is a medium-severity missing authorization vulnerability in langgenius dify, published on 18 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32796 exists.\n\nAffected product: langgenius dify. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-32796/ (Markdown: https://insights.sbomify.com/CVE-2025-32796/index.md)","id":"CVE-2025-32796","markdown":"https://insights.sbomify.com/CVE-2025-32796/index.md","name":"CVE-2025-32796","record":{"aliases":["GHSA-hqcx-598m-pjq4"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"LLM app development platform","requires_auth":"low_privilege","summary":"Non-admin users can unauthorizedly enable or disable applications via API, disrupting service availability and functionality.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"dify","vendor":"langgenius"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"},{"id":"CWE-284","name":"Improper Access Control"}],"description":"Dify is an open-source LLM app development platform. Prior to version 0.6.12, a vulnerability was identified in the DIFY where normal users can enable or disable apps through the API, even though the web UI button for this action is disabled and normal users are not permitted to make such changes. This access control flaw allows non-admin users to make unauthorized changes, which can disrupt the functionality and availability of the APPS. This issue has been patched in version 0.6.12. A workaround for this vulnerability involves updating the API access control mechanisms to enforce stricter user role permissions and implementing role-based access controls (RBAC) to ensure that only users with admin privileges can send enable or disable requests for apps.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Dify Allows Unauthorized APP Enable/Disable via API","id":"CVE-2025-32796","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"missing_authorization","year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"Conda-build Insecure Build Script Permissions Enabling Arbitrary Code Execution","id":"CVE-2025-32797"},"packages":[],"prev":{"headline":"Dify Allows Insecure User Role Access Control for APP Editing","id":"CVE-2025-32795"},"products":["dify"],"published":"2025-04-18","related":[{"cvss_score":9.8,"headline":"Hardcoded credentials in n/a","id":"CVE-2025-56157","kev_date_added":null,"published":"2025-12-18"},{"cvss_score":9.8,"headline":"Unsanitized Input in langgenius/dify","id":"CVE-2025-3466","kev_date_added":null,"published":"2025-07-07"},{"cvss_score":9.1,"headline":"Misconfiguration in n/a","id":"CVE-2025-63386","kev_date_added":null,"published":"2025-12-18"},{"cvss_score":9.1,"headline":"Misconfiguration in n/a","id":"CVE-2025-63388","kev_date_added":null,"published":"2025-12-18"},{"cvss_score":8.8,"headline":"Code Injection in langgenius/dify","id":"CVE-2024-10252","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":8.1,"headline":"Authentication Bypass in langgenius/dify","id":"CVE-2024-12776","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":8,"headline":"XSS Vulnerability in langgenius/dify","id":"CVE-2025-3467","kev_date_added":null,"published":"2025-07-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-18","vendors":["langgenius"]},"summary":"Non-admin users can unauthorizedly enable or disable applications via API, disrupting service availability and functionality.","url":"https://insights.sbomify.com/CVE-2025-32796/"}