# CVE-2025-32796: Dify Allows Unauthorized APP Enable/Disable via API

> Non-admin users can unauthorizedly enable or disable applications via API, disrupting service availability and functionality.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Apr 2025
- **Updated:** 18 Apr 2025
- **Also known as:** GHSA-hqcx-598m-pjq4

## What is CVE-2025-32796?

CVE-2025-32796 is a medium-severity missing authorization vulnerability in langgenius dify, published on 18 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Dify is an open-source LLM app development platform. Prior to version 0.6.12, a vulnerability was identified in the DIFY where normal users can enable or disable apps through the API, even though the web UI button for this action is disabled and normal users are not permitted to make such changes. This access control flaw allows non-admin users to make unauthorized changes, which can disrupt the functionality and availability of the APPS. This issue has been patched in version 0.6.12. A workaround for this vulnerability involves updating the API access control mechanisms to enforce stricter user role permissions and implementing role-based access controls (RBAC) to ensure that only users with admin privileges can send enable or disable requests for apps.

Weakness: CWE-863 (Incorrect Authorization), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2025-32796?

It affects 1 product.


Products: Langgenius Dify.

## How do I fix CVE-2025-32796?

No fix has been published for CVE-2025-32796 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-32796 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32796 exists.

## Other vulnerabilities in langgenius dify

- [CVE-2025-56157](https://insights.sbomify.com/CVE-2025-56157/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2025-3466](https://insights.sbomify.com/CVE-2025-3466/): Unsanitized Input in langgenius/dify (critical 9.8)
- [CVE-2025-63386](https://insights.sbomify.com/CVE-2025-63386/): Misconfiguration in n/a (critical 9.1)
- [CVE-2025-63388](https://insights.sbomify.com/CVE-2025-63388/): Misconfiguration in n/a (critical 9.1)
- [CVE-2024-10252](https://insights.sbomify.com/CVE-2024-10252/): Code Injection in langgenius/dify (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32796 and fix it if it is affected.

What it is: CVE-2025-32796 is a medium-severity missing authorization vulnerability in langgenius dify, published on 18 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32796 exists.

Affected product: langgenius dify. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32796/ (Markdown: https://insights.sbomify.com/CVE-2025-32796/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32796
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32796
- OSV: https://osv.dev/vulnerability/CVE-2025-32796

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32796/
Summaries are generated and may contain mistakes; the official description above is the record.
