# CVE-2025-32800: Supply chain in conda-build

> Attackers can hijack a missing dependency namespace to inject malicious code during package installation, affecting developers using Conda-build.

- **Severity:** High 7.2 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Jun 2025
- **Updated:** 17 Jun 2025
- **Also known as:** GHSA-83gh-p93g-cwgx

## What is CVE-2025-32800?

CVE-2025-32800 is a high-severity vulnerability in conda-build, published on 16 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Conda-build contains commands and tools to build conda packages. Prior to version 25.3.0, the pyproject.toml lists conda-index as a Python dependency. This package is not published in PyPI. An attacker could claim this namespace and upload arbitrary (malicious) code to the package, and then exploit pip install commands by injecting the malicious dependency in the solve. This issue has been fixed in version 25.3.0. A workaround involves using --no-deps for pip install-ing the project from the repository.

Weakness: CWE-1357 (Reliance on Insufficiently Trustworthy Component)

## Which versions are affected by CVE-2025-32800?

It affects 1 product.


Products: Anaconda Conda-Build.

## How do I fix CVE-2025-32800?

No fix has been published for CVE-2025-32800 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-32800 being exploited?

There is no known exploitation of CVE-2025-32800 in the wild and no public exploit code.

## Other vulnerabilities in conda-build

- [CVE-2025-32798](https://insights.sbomify.com/CVE-2025-32798/): Conda-build Allows Arbitrary Code Execution via Malicious Recipe Selectors (high 8.2)
- [CVE-2025-32797](https://insights.sbomify.com/CVE-2025-32797/): Conda-build Insecure Build Script Permissions Enabling Arbitrary Code Execution (medium 6.0)
- [CVE-2025-32799](https://insights.sbomify.com/CVE-2025-32799/): Conda-build Vulnerable to Path Traversal via Malicious Tar File (medium 5.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32800 and fix it if it is affected.

What it is: CVE-2025-32800 is a high-severity vulnerability in conda-build, published on 16 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-32800 in the wild and no public exploit code.

Affected product: conda-build. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32800/ (Markdown: https://insights.sbomify.com/CVE-2025-32800/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32800
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32800
- OSV: https://osv.dev/vulnerability/CVE-2025-32800

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32800/
Summaries are generated and may contain mistakes; the official description above is the record.
