CVE-2025-32873 Django has a denial-of-service possibility in strip_tags()
Attackers can cause denial of service in Django applications by sending inputs with large sequences of incomplete HTML tags to the strip_tags function.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-32873?
CVE-2025-32873 is a medium-severity denial of service vulnerability in Djangoproject Django, published on 8 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in Django 4.2 before 4.2.21, 5.1 before 5.1.9, and 5.2 before 5.2.1. The django.utils.html.strip_tags() function is vulnerable to a potential denial-of-service (slow performance) when processing inputs containing large sequences of incomplete HTML tags. The template filter striptags is also vulnerable, because it is built on top of strip_tags().
Weakness: CWE-770
Which versions are affected by CVE-2025-32873?
8 open source packages ship an affected version, including django and Django. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
django Bitnami | From 4.2.0 | 4.2.21, 5.1.9, 5.2.5 |
django PyPI | From 4.2 | 4.2.21, 5.1.9, 5.2.1 |
django PyPI | From 4.2 | 4.2.21 |
django PyPI | From 5.1 | 5.1.9 |
django PyPI | From 5.2 | 5.2.1 |
Django PyPI | From 4.2 | 4.2.21 |
2 more packages
Django PyPI | From 5.1 | 5.1.9 |
Django PyPI | From 5.2 | 5.2.1 |
Linux distribution packages (5)
python-Django SUSE:Linux Enterprise Module for Package Hub 15 SP6 | All versions | 4.2.11-150600.3.21.1 |
python-Django SUSE:Linux Enterprise Module for Package Hub 15 SP7 | All versions | 4.2.11-150600.3.21.1 |
python-Django openSUSE:Leap 15.6 | All versions | 4.2.11-150600.3.21.1 |
python-Django openSUSE:Tumbleweed | All versions | 5.2.1-1.1 |
python-Django4 openSUSE:Tumbleweed | All versions | 4.2.21-1.1 |
Products include Djangoproject Django.
How do I fix CVE-2025-32873?
Upgrade django to a fixed version for your release line: 4.2.21, 5.1.9, 5.2.5 or 5.2.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-32873 being exploited?
There is no known exploitation of CVE-2025-32873 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Djangoproject Django
- CVE-2026-4277 Privilege abuse in GenericInlineModelAdmin
- CVE-2024-53908 Django SQL injection in HasKey(lhs, rhs) on Oracle
- CVE-2024-42005 Django SQL injection vulnerability
- CVE-2023-31047 Django bypasses validation when using one form field to upload multiple files
- CVE-2022-34265 Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection
Sources
Also known as BIT-django-2025-32873, DEBIAN-CVE-2025-32873, GHSA-8j24-cjrq-gr2m, MGASA-2025-0153, OESA-2025-1524, PYSEC-2025-37 and 7 more.