# CVE-2025-32873: Django has a denial-of-service possibility in strip_tags()

> Attackers can cause denial of service in Django applications by sending inputs with large sequences of incomplete HTML tags to the strip_tags function.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2025
- **Updated:** 8 May 2025
- **Also known as:** BIT-django-2025-32873, DEBIAN-CVE-2025-32873, GHSA-8j24-cjrq-gr2m, MGASA-2025-0153, OESA-2025-1524, PYSEC-2025-37, SUSE-SU-2025:01523-1, SUSE-SU-2025:1523-1, UBUNTU-CVE-2025-32873, USN-7501-1, USN-7501-2, openSUSE-SU-2025:15082-1, openSUSE-SU-2025:15087-1

## What is CVE-2025-32873?

CVE-2025-32873 is a medium-severity denial of service vulnerability in Djangoproject Django, published on 8 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Django 4.2 before 4.2.21, 5.1 before 5.1.9, and 5.2 before 5.2.1. The django.utils.html.strip_tags() function is vulnerable to a potential denial-of-service (slow performance) when processing inputs containing large sequences of incomplete HTML tags. The template filter striptags is also vulnerable, because it is built on top of strip_tags().

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-32873?

8 open source packages ship an affected version, including django and Django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 4.2.0 | 4.2.21, 5.1.9, 5.2.5 |
| `django` | PyPI | From 4.2 | 4.2.21, 5.1.9, 5.2.1 |
| `django` | PyPI | From 4.2 | 4.2.21 |
| `django` | PyPI | From 5.1 | 5.1.9 |
| `django` | PyPI | From 5.2 | 5.2.1 |
| `Django` | PyPI | From 4.2 | 4.2.21 |
| `Django` | PyPI | From 5.1 | 5.1.9 |
| `Django` | PyPI | From 5.2 | 5.2.1 |
| `python-Django` | SUSE:Linux Enterprise Module for Package Hub 15 SP6 | All versions | 4.2.11-150600.3.21.1 |
| `python-Django` | SUSE:Linux Enterprise Module for Package Hub 15 SP7 | All versions | 4.2.11-150600.3.21.1 |
| `python-Django` | openSUSE:Leap 15.6 | All versions | 4.2.11-150600.3.21.1 |
| `python-Django` | openSUSE:Tumbleweed | All versions | 5.2.1-1.1 |
| `python-Django4` | openSUSE:Tumbleweed | All versions | 4.2.21-1.1 |

Products: Djangoproject Django.

## How do I fix CVE-2025-32873?

Upgrade django to a fixed version for your release line: 4.2.21, 5.1.9, 5.2.5 or 5.2.1.

## Is CVE-2025-32873 being exploited?

There is no known exploitation of CVE-2025-32873 in the wild and no public exploit code.

Public exploit code:

- Django Security Issue (CVE-2025-32873) (github_poc): https://github.com/Apollo-R3bot/django-vulnerability-CVE-2025-32873

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32873 and fix it if it is affected.

What it is: CVE-2025-32873 is a medium-severity denial of service vulnerability in Djangoproject Django, published on 8 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-32873 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 4.2.0; fixed in 4.2.21, 5.1.9, 5.2.5
- django (PyPI): affected from 4.2; fixed in 4.2.21, 5.1.9, 5.2.1
- django (PyPI): affected from 4.2; fixed in 4.2.21
- django (PyPI): affected from 5.1; fixed in 5.1.9
- django (PyPI): affected from 5.2; fixed in 5.2.1
- Django (PyPI): affected from 4.2; fixed in 4.2.21
- Django (PyPI): affected from 5.1; fixed in 5.1.9
- Django (PyPI): affected from 5.2; fixed in 5.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32873/ (Markdown: https://insights.sbomify.com/CVE-2025-32873/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32873
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32873
- OSV: https://osv.dev/vulnerability/CVE-2025-32873

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32873/
Summaries are generated and may contain mistakes; the official description above is the record.
