# CVE-2025-32897: Apache Seata (incubating): Deserialization of untrusted Data in Apache Seata Server

> An attacker with internal network access can execute arbitrary code via deserialization in Apache Seata's optional Raft cluster mode.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jun 2025
- **Updated:** 30 Mar 2026
- **Also known as:** GHSA-m964-fjrh-xxq2

## What is CVE-2025-32897?

CVE-2025-32897 is a critical unsafe deserialization vulnerability in Apache Seata (incubating), published on 28 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Deserialization of Untrusted Data vulnerability in Apache Seata (incubating).

This security vulnerability is the same as CVE-2024-47552, but the version range described in the CVE-2024-47552 definition is too narrow.
This issue affects Apache Seata (incubating): from 2.0.0 before 2.3.0.

Severity Justification:
The Apache Seata security team assesses the severity of this vulnerability as "Low" due to stringent real-world mitigating factors. First, the vulnerability is strictly isolated to the Raft cluster mode, an optional and non-default feature introduced in v2.0.0, while most users rely on the unaffected traditional architecture. Second, Seata is an internal middleware; communication between TC and RM/TM occurs entirely within trusted internal networks. An attacker would require prior, unauthorized access to the Intranet to exploit this, making external exploitation highly improbable.
Users are recommended to upgrade to version 2.3.0, which fixes the issue.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-32897?

2 open source packages ship an affected version, including org.apache.seata:seata-config-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.seata:seata-config-core` | Maven | From 2.0.0 | 2.3.0 |
| `org.apache.seata:seata-config-core` | Maven | From 2.0.0 | 2.3.0 |

Products: Apache Seata.

## How do I fix CVE-2025-32897?

Upgrade org.apache.seata:seata-config-core to 2.3.0 or later.

## Is CVE-2025-32897 being exploited?

There is no known exploitation of CVE-2025-32897 in the wild and no public exploit code.

## Other vulnerabilities in Apache Seata (incubating)

- [CVE-2025-53606](https://insights.sbomify.com/CVE-2025-53606/): Apache Seata (incubating): Deserialization of untrusted Data in Apache Seata Server (critical 9.8)
- [CVE-2024-47552](https://insights.sbomify.com/CVE-2024-47552/): Apache Seata (incubating): Deserialization of untrusted Data in jraft mode in Apache Seata Server (critical 9.8)
- [CVE-2024-22399](https://insights.sbomify.com/CVE-2024-22399/): Apache Seata: Remote Code Execution vulnerability via Hessian Deserialization in Apache Seata Server (critical 9.8)
- [CVE-2024-54016](https://insights.sbomify.com/CVE-2024-54016/): compression bomb attack in Apache Seata Server (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32897 and fix it if it is affected.

What it is: CVE-2025-32897 is a critical unsafe deserialization vulnerability in Apache Seata (incubating), published on 28 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-32897 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.seata:seata-config-core (Maven): affected from 2.0.0; fixed in 2.3.0
- org.apache.seata:seata-config-core (Maven): affected from 2.0.0; fixed in 2.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32897/ (Markdown: https://insights.sbomify.com/CVE-2025-32897/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32897
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32897
- OSV: https://osv.dev/vulnerability/CVE-2025-32897

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32897/
Summaries are generated and may contain mistakes; the official description above is the record.
