{"answers":{"affected":"2 open source packages ship an affected version, including tcg/voyager.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32931 exists.","fix":"No fix has been published for CVE-2025-32931 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-32931 is a critical command injection vulnerability in DevDojo Voyager, published on 14 Apr 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-32931 and fix it if it is affected.\n\nWhat it is: CVE-2025-32931 is a critical command injection vulnerability in DevDojo Voyager, published on 14 Apr 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32931 exists.\n\nAffected packages and fixed versions:\n- tcg/voyager (Packagist): affected from 1.4.0 up to 1.8.0; no fix listed\n- tcg/voyager (Packagist): affected from 1.4.0 up to 1.8.0; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-32931/ (Markdown: https://insights.sbomify.com/CVE-2025-32931/index.md)","id":"CVE-2025-32931","markdown":"https://insights.sbomify.com/CVE-2025-32931/index.md","name":"CVE-2025-32931","record":{"aliases":["GHSA-qq2h-m2hj-hrff"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Laravel admin package","requires_auth":"high_privilege","summary":"Authenticated administrators can execute arbitrary OS commands in DevDojo Voyager when using Laravel 8 or later.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"}],"description":"DevDojo Voyager 1.4.0 through 1.8.0, when Laravel 8 or later is used, allows authenticated administrators to execute arbitrary OS commands via a specific php artisan command.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"DevDojo Voyager Argument Injection vulnerability","id":"CVE-2025-32931","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"Cross-site scripting in FortiSOAR","id":"CVE-2025-32932"},"packages":[{"ecosystem":"Packagist","fixed":[],"introduced":["1.4.0"],"last_affected":["1.8.0"],"package":"tcg/voyager","purl":null,"source":"GHSA-qq2h-m2hj-hrff"},{"ecosystem":"Packagist","fixed":[],"introduced":["1.4.0"],"last_affected":["1.8.0"],"package":"tcg/voyager","purl":"pkg:composer/tcg/voyager","source":"GHSA-qq2h-m2hj-hrff"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2025-32930"},"products":["Voyager"],"published":"2025-04-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-14","vendors":["DevDojo"]},"summary":"Authenticated administrators can execute arbitrary OS commands in DevDojo Voyager when using Laravel 8 or later.","url":"https://insights.sbomify.com/CVE-2025-32931/"}