# CVE-2025-32959: CUBA Vulnerable to Denial of Service (DoS) in the File Storage

> Attackers can cause denial of service by uploading excessively large files to the local file storage, exhausting server space.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Apr 2025
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-w3mp-6vrj-875g

## What is CVE-2025-32959?

CVE-2025-32959 is a medium-severity denial of service vulnerability in cuba-platform cuba, published on 22 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

CUBA Platform is a high level framework for enterprise applications development. Prior to version 7.2.23, the local file storage implementation does not restrict the size of uploaded files. An attacker could exploit this by uploading excessively large files, potentially causing the server to run out of space and return HTTP 500 error, resulting in a denial of service. This issue has been patched in version 7.2.23. A workaround is provided on the Jmix documentation website.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-32959?

2 open source packages ship an affected version, including com.haulmont.cuba:cuba-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.haulmont.cuba:cuba-core` | Maven | All versions | 7.2.23 |
| `com.haulmont.cuba:cuba-core` | Maven | All versions | 7.2.23 |

## How do I fix CVE-2025-32959?

Upgrade com.haulmont.cuba:cuba-core to 7.2.23 or later.

## Is CVE-2025-32959 being exploited?

There is no known exploitation of CVE-2025-32959 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32959 and fix it if it is affected.

What it is: CVE-2025-32959 is a medium-severity denial of service vulnerability in cuba-platform cuba, published on 22 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-32959 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.haulmont.cuba:cuba-core (Maven): affected all versions; fixed in 7.2.23
- com.haulmont.cuba:cuba-core (Maven): affected all versions; fixed in 7.2.23

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32959/ (Markdown: https://insights.sbomify.com/CVE-2025-32959/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32959
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32959
- OSV: https://osv.dev/vulnerability/CVE-2025-32959

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32959/
Summaries are generated and may contain mistakes; the official description above is the record.
