# CVE-2025-32960: CUBA Generic REST API Vulnerable to Cross-Site Scripting (XSS) in the /files Endpoint

> Attackers can execute malicious JavaScript in browsers via the /files endpoint if a malicious file is uploaded, affecting CUBA REST API users.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Apr 2025
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-88h5-34xw-2q56

## What is CVE-2025-32960?

CVE-2025-32960 is a medium-severity cross-site scripting vulnerability in cuba-platform restapi, published on 22 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The CUBA REST API add-on performs operations on data and entities. Prior to version 7.2.7, the input parameter, which consists of a file path and name, can be manipulated to return the Content-Type header with text/html if the name part ends with .html. This could allow malicious JavaScript code to be executed in the browser. For a successful attack, a malicious file needs to be uploaded beforehand. This issue has been patched in version 7.2.7. A workaround is provided on the Jmix documentation website.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-32960?

2 open source packages ship an affected version, including com.haulmont.addon.restapi:restapi-rest-api.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.haulmont.addon.restapi:restapi-rest-api` | Maven | All versions | 7.2.7 |
| `com.haulmont.addon.restapi:restapi-rest-api` | Maven | All versions | 7.2.7 |

## How do I fix CVE-2025-32960?

Upgrade com.haulmont.addon.restapi:restapi-rest-api to 7.2.7 or later.

## Is CVE-2025-32960 being exploited?

There is no known exploitation of CVE-2025-32960 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32960 and fix it if it is affected.

What it is: CVE-2025-32960 is a medium-severity cross-site scripting vulnerability in cuba-platform restapi, published on 22 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-32960 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.haulmont.addon.restapi:restapi-rest-api (Maven): affected all versions; fixed in 7.2.7
- com.haulmont.addon.restapi:restapi-rest-api (Maven): affected all versions; fixed in 7.2.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32960/ (Markdown: https://insights.sbomify.com/CVE-2025-32960/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32960
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32960
- OSV: https://osv.dev/vulnerability/CVE-2025-32960

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32960/
Summaries are generated and may contain mistakes; the official description above is the record.
