{"answers":{"affected":"2 open source packages ship an affected version, including com.haulmont.addon.jpawebapi:jpawebapi-jpawebapi.","exploited":"There is no known exploitation of CVE-2025-32961 in the wild and no public exploit code.","fix":"Upgrade com.haulmont.addon.jpawebapi:jpawebapi-jpawebapi to 1.1.1 or later.","what":"CVE-2025-32961 is a medium-severity cross-site scripting vulnerability in cuba-platform jpawebapi, published on 22 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-32961 and fix it if it is affected.\n\nWhat it is: CVE-2025-32961 is a medium-severity cross-site scripting vulnerability in cuba-platform jpawebapi, published on 22 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-32961 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.haulmont.addon.jpawebapi:jpawebapi-jpawebapi (Maven): affected all versions; fixed in 1.1.1\n- com.haulmont.addon.jpawebapi:jpawebapi-jpawebapi (Maven): affected all versions; fixed in 1.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-32961/ (Markdown: https://insights.sbomify.com/CVE-2025-32961/index.md)","id":"CVE-2025-32961","markdown":"https://insights.sbomify.com/CVE-2025-32961/index.md","name":"CVE-2025-32961","record":{"aliases":["GHSA-hg25-w3vg-7279"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"CUBA JPA Web API","requires_auth":"low_privilege","summary":"Attackers can execute malicious JavaScript in browsers via the /download endpoint if a malicious file is uploaded, affecting CUBA JPA Web API users.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The Cuba JPA web API enables loading and saving any entities defined in the application data model by sending simple HTTP requests. Prior to version 1.1.1, the input parameter, which consists of a file path and name, can be manipulated to return the Content-Type header with text/html if the name part ends with .html. This could allow malicious JavaScript code to be executed in the browser. For a successful attack, a malicious file needs to be uploaded beforehand. This issue has been patched in version 1.1.1. A workaround is provided on the Jmix documentation website.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CUBA JPA Web API Vulnerable to Cross-Site Scripting (XSS) in the /download Endpoint","id":"CVE-2025-32961","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":4,"next":{"headline":"Flask-AppBuilder open redirect vulnerability using HTTP host injection","id":"CVE-2025-32962"},"packages":[{"ecosystem":"Maven","fixed":["1.1.1"],"introduced":["0"],"last_affected":[],"package":"com.haulmont.addon.jpawebapi:jpawebapi-jpawebapi","purl":null,"source":"GHSA-hg25-w3vg-7279"},{"ecosystem":"Maven","fixed":["1.1.1"],"introduced":["0"],"last_affected":[],"package":"com.haulmont.addon.jpawebapi:jpawebapi-jpawebapi","purl":"pkg:maven/com.haulmont.addon.jpawebapi/jpawebapi-jpawebapi","source":"GHSA-hg25-w3vg-7279"}],"prev":{"headline":"CUBA Generic REST API Vulnerable to Cross-Site Scripting (XSS) in the /files Endpoint","id":"CVE-2025-32960"},"products":["jpawebapi"],"published":"2025-04-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["cuba-platform"]},"summary":"Attackers can execute malicious JavaScript in browsers via the /download endpoint if a malicious file is uploaded, affecting CUBA JPA Web API users.","url":"https://insights.sbomify.com/CVE-2025-32961/"}