# CVE-2025-32961: CUBA JPA Web API Vulnerable to Cross-Site Scripting (XSS) in the /download Endpoint

> Attackers can execute malicious JavaScript in browsers via the /download endpoint if a malicious file is uploaded, affecting CUBA JPA Web API users.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Apr 2025
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-hg25-w3vg-7279

## What is CVE-2025-32961?

CVE-2025-32961 is a medium-severity cross-site scripting vulnerability in cuba-platform jpawebapi, published on 22 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Cuba JPA web API enables loading and saving any entities defined in the application data model by sending simple HTTP requests. Prior to version 1.1.1, the input parameter, which consists of a file path and name, can be manipulated to return the Content-Type header with text/html if the name part ends with .html. This could allow malicious JavaScript code to be executed in the browser. For a successful attack, a malicious file needs to be uploaded beforehand. This issue has been patched in version 1.1.1. A workaround is provided on the Jmix documentation website.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-32961?

2 open source packages ship an affected version, including com.haulmont.addon.jpawebapi:jpawebapi-jpawebapi.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.haulmont.addon.jpawebapi:jpawebapi-jpawebapi` | Maven | All versions | 1.1.1 |
| `com.haulmont.addon.jpawebapi:jpawebapi-jpawebapi` | Maven | All versions | 1.1.1 |

## How do I fix CVE-2025-32961?

Upgrade com.haulmont.addon.jpawebapi:jpawebapi-jpawebapi to 1.1.1 or later.

## Is CVE-2025-32961 being exploited?

There is no known exploitation of CVE-2025-32961 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32961 and fix it if it is affected.

What it is: CVE-2025-32961 is a medium-severity cross-site scripting vulnerability in cuba-platform jpawebapi, published on 22 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-32961 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.haulmont.addon.jpawebapi:jpawebapi-jpawebapi (Maven): affected all versions; fixed in 1.1.1
- com.haulmont.addon.jpawebapi:jpawebapi-jpawebapi (Maven): affected all versions; fixed in 1.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32961/ (Markdown: https://insights.sbomify.com/CVE-2025-32961/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32961
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32961
- OSV: https://osv.dev/vulnerability/CVE-2025-32961

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32961/
Summaries are generated and may contain mistakes; the official description above is the record.
