# CVE-2025-32962: Flask-AppBuilder open redirect vulnerability using HTTP host injection

> An unauthenticated attacker can perform an open redirect by manipulating the HTTP Host header in Flask-AppBuilder applications.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 May 2025
- **Updated:** 16 May 2025
- **Also known as:** CLEANSTART-2026-XC11727, ECHO-dcfd-9155-eb11, GHSA-99pm-ch96-ccp2, MINI-xgx2-7p69-f84f, PYSEC-2026-1379, ROOT-APP-PYPI-CVE-2025-32962

## What is CVE-2025-32962?

CVE-2025-32962 is a medium-severity vulnerability in dpgaspar Flask-AppBuilder, published on 16 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Flask-AppBuilder is an application development framework built on top of Flask. Versions prior to 4.6.2 would allow for a malicious unauthenticated actor to perform an open redirect by manipulating the Host header in HTTP requests. Flask-AppBuilder 4.6.2 introduced the `FAB_SAFE_REDIRECT_HOSTS` configuration variable, which allows administrators to explicitly define which domains are considered safe for redirection. As a workaround, use a reverse proxy to enforce trusted host headers.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2025-32962?

3 open source packages ship an affected version, including flask-appbuilder. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flask-appbuilder` | PyPI | All versions | 4.6.2 |
| `flask-appbuilder` | PyPI | All versions | 4.6.2 |
| `flask-appbuilder` | PyPI | All versions | 4.6.2 |

Products: Dpgaspar Flask-Appbuilder.

## How do I fix CVE-2025-32962?

Upgrade flask-appbuilder to 4.6.2 or later.

## Is CVE-2025-32962 being exploited?

There is no known exploitation of CVE-2025-32962 in the wild and no public exploit code.

## Other vulnerabilities in dpgaspar Flask-AppBuilder

- [CVE-2024-25128](https://insights.sbomify.com/CVE-2024-25128/): Flask-AppBuilder incorrect authentication when using auth type OpenID (critical 9.1)
- [CVE-2021-41265](https://insights.sbomify.com/CVE-2021-41265/): Improper Authentication in Flask-AppBuilder (high 8.1)
- [CVE-2023-29005](https://insights.sbomify.com/CVE-2023-29005/): No Rate Limiting on Login AUTH DB (high 7.5)
- [CVE-2021-32805](https://insights.sbomify.com/CVE-2021-32805/): URL Redirection to Untrusted Site ('Open Redirect') in Flask-AppBuilder (high 7.2)
- [CVE-2025-58065](https://insights.sbomify.com/CVE-2025-58065/): Flask App Builder has an Authentication Bypass vulnerability when using non AUTH_DB methods (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32962 and fix it if it is affected.

What it is: CVE-2025-32962 is a medium-severity vulnerability in dpgaspar Flask-AppBuilder, published on 16 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-32962 in the wild and no public exploit code.

Affected packages and fixed versions:
- flask-appbuilder (PyPI): affected all versions; fixed in 4.6.2
- flask-appbuilder (PyPI): affected all versions; fixed in 4.6.2
- flask-appbuilder (PyPI): affected all versions; fixed in 4.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32962/ (Markdown: https://insights.sbomify.com/CVE-2025-32962/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32962
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32962
- OSV: https://osv.dev/vulnerability/CVE-2025-32962

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32962/
Summaries are generated and may contain mistakes; the official description above is the record.
