CVE-2025-32968 org.xwiki.platform:xwiki-platform-oldcore allows SQL injection in short form select requests through the script query API
An attacker with script rights can perform blind SQL injection via the script query API to read or modify database contents.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-32968?
CVE-2025-32968 is a high-severity SQL injection vulnerability in Xwiki Xwiki, published on 23 Apr 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
XWiki is a generic wiki platform. In versions starting from 1.6-milestone-1 to before 15.10.16, 16.4.6, and 16.10.1, it is possible for a user with SCRIPT right to escape from the HQL execution context and perform a blind SQL injection to execute arbitrary SQL statements on the database backend. Depending on the used database backend, the attacker may be able to not only obtain confidential information such as password hashes from the database, but also execute UPDATE/INSERT/DELETE queries. This issue has been patched in versions 16.10.1, 16.4.6 and 15.10.16. There is no known workaround, other than upgrading XWiki. The protection added to this REST API is the same as the one used to validate complete select queries, making it more consistent. However, while the script API always had this protection for complete queries, it's important to note that it's a very strict protection and some valid, but complex, queries might suddenly require the author to have programming right.
Weakness: CWE-89
Which versions are affected by CVE-2025-32968?
6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-oldcore Maven | From 1.6-milestone-1 | 15.10.16 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 1.6-milestone-1 | 15.10.16 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 16.0.0-rc-1 | 16.4.6 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 16.0.0-rc-1 | 16.4.6 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 16.5.0-rc-1 | 16.10.1 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 16.5.0-rc-1 | 16.10.1 |
Products include Xwiki Xwiki.
How do I fix CVE-2025-32968?
Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 15.10.16, 16.4.6 or 16.10.1.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2025-32968 being exploited?
There is no known exploitation of CVE-2025-32968 in the wild and no public exploit code.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-g9jj-75mx-wjcx.