# CVE-2025-32968: org.xwiki.platform:xwiki-platform-oldcore allows SQL injection in short form select requests through the script query API

> An attacker with script rights can perform blind SQL injection via the script query API to read or modify database contents.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Apr 2025
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-g9jj-75mx-wjcx

## What is CVE-2025-32968?

CVE-2025-32968 is a high-severity SQL injection vulnerability in Xwiki Xwiki, published on 23 Apr 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

XWiki is a generic wiki platform. In versions starting from 1.6-milestone-1 to before 15.10.16, 16.4.6, and 16.10.1, it is possible for a user with SCRIPT right to escape from the HQL execution context and perform a blind SQL injection to execute arbitrary SQL statements on the database backend. Depending on the used database backend, the attacker may be able to not only obtain confidential information such as password hashes from the database, but also execute UPDATE/INSERT/DELETE queries. This issue has been patched in versions 16.10.1, 16.4.6 and 15.10.16. There is no known workaround, other than upgrading XWiki. The protection added to this REST API is the same as the one used to validate complete select queries, making it more consistent. However, while the script API always had this protection for complete queries, it's important to note that it's a very strict protection and some valid, but complex, queries might suddenly require the author to have programming right.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-32968?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 1.6-milestone-1 | 15.10.16 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 1.6-milestone-1 | 15.10.16 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 16.0.0-rc-1 | 16.4.6 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 16.0.0-rc-1 | 16.4.6 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 16.5.0-rc-1 | 16.10.1 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 16.5.0-rc-1 | 16.10.1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2025-32968?

Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 15.10.16, 16.4.6 or 16.10.1.

## Is CVE-2025-32968 being exploited?

There is no known exploitation of CVE-2025-32968 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32968 and fix it if it is affected.

What it is: CVE-2025-32968 is a high-severity SQL injection vulnerability in Xwiki Xwiki, published on 23 Apr 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-32968 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 1.6-milestone-1; fixed in 15.10.16
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 1.6-milestone-1; fixed in 15.10.16
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 16.0.0-rc-1; fixed in 16.4.6
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 16.0.0-rc-1; fixed in 16.4.6
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 16.5.0-rc-1; fixed in 16.10.1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 16.5.0-rc-1; fixed in 16.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32968/ (Markdown: https://insights.sbomify.com/CVE-2025-32968/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32968
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32968
- OSV: https://osv.dev/vulnerability/CVE-2025-32968

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32968/
Summaries are generated and may contain mistakes; the official description above is the record.
