# CVE-2025-32969: org.xwiki.platform:xwiki-platform-rest-server allows SQL injection in query endpoint of REST API

> Remote unauthenticated attackers can perform blind SQL injection via the REST API to read or modify database contents, including password hashes.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Apr 2025
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-f69v-xrj8-rhxf

## What is CVE-2025-32969?

CVE-2025-32969 is a critical SQL injection vulnerability in Xwiki Xwiki, published on 23 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki is a generic wiki platform. In versions starting from 1.8 and prior to 15.10.16, 16.4.6, and 16.10.1, it is possible for a remote unauthenticated user to escape from the HQL execution context and perform a blind SQL injection to execute arbitrary SQL statements on the database backend, including when "Prevent unregistered users from viewing pages, regardless of the page rights" and "Prevent unregistered users from editing pages, regardless of the page rights" options are enabled. Depending on the used database backend, the attacker may be able to not only obtain confidential information such as password hashes from the database, but also execute UPDATE/INSERT/DELETE queries. This issue has been patched in versions 16.10.1, 16.4.6 and 15.10.16. There is no known workaround, other than upgrading XWiki.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-32969?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-rest-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 1.8 | 15.10.16 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 1.8 | 15.10.16 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 16.0.0-rc-1 | 16.4.6 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 16.0.0-rc-1 | 16.4.6 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 16.5.0-rc-1 | 16.10.1 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 16.5.0-rc-1 | 16.10.1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2025-32969?

Upgrade org.xwiki.platform:xwiki-platform-rest-server to a fixed version for your release line: 15.10.16, 16.4.6 or 16.10.1.

## Is CVE-2025-32969 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32969 exists.

Public exploit code:

- XWiki REST API Query - SQL Injection (nuclei): http/cves/2025/CVE-2025-32969.yaml

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32969 and fix it if it is affected.

What it is: CVE-2025-32969 is a critical SQL injection vulnerability in Xwiki Xwiki, published on 23 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32969 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 1.8; fixed in 15.10.16
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 1.8; fixed in 15.10.16
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 16.0.0-rc-1; fixed in 16.4.6
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 16.0.0-rc-1; fixed in 16.4.6
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 16.5.0-rc-1; fixed in 16.10.1
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 16.5.0-rc-1; fixed in 16.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32969/ (Markdown: https://insights.sbomify.com/CVE-2025-32969/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32969
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32969
- OSV: https://osv.dev/vulnerability/CVE-2025-32969

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32969/
Summaries are generated and may contain mistakes; the official description above is the record.
