# CVE-2025-32970: org.xwiki.platform:xwiki-platform-wysiwyg-api Open Redirect vulnerability

> Attackers can craft URLs on XWiki instances that redirect users to arbitrary external sites, potentially facilitating phishing attacks.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Apr 2025
- **Updated:** 30 Apr 2025
- **Also known as:** GHSA-pjhg-9wr9-rj96

## What is CVE-2025-32970?

CVE-2025-32970 is a medium-severity vulnerability in Xwiki Xwiki, published on 30 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

XWiki is a generic wiki platform. In versions starting from 13.5-rc-1 to before 15.10.13, from 16.0.0-rc-1 to before 16.4.4, and from 16.5.0-rc-1 to before 16.8.0, an open redirect vulnerability in the HTML conversion request filter allows attackers to construct URLs on an XWiki instance that redirects to any URL. This issue has been patched in versions 15.10.13, 16.4.4, and 16.8.0.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2025-32970?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-wysiwyg-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-wysiwyg-api` | Maven | From 13.5-rc-1 | 15.10.13 |
| `org.xwiki.platform:xwiki-platform-wysiwyg-api` | Maven | From 13.5-rc-1 | 15.10.13 |
| `org.xwiki.platform:xwiki-platform-wysiwyg-api` | Maven | From 16.0.0-rc-1 | 16.4.4 |
| `org.xwiki.platform:xwiki-platform-wysiwyg-api` | Maven | From 16.0.0-rc-1 | 16.4.4 |
| `org.xwiki.platform:xwiki-platform-wysiwyg-api` | Maven | From 16.5.0-rc-1 | 16.8.0 |
| `org.xwiki.platform:xwiki-platform-wysiwyg-api` | Maven | From 16.5.0-rc-1 | 16.8.0 |

Products: Xwiki Xwiki.

## How do I fix CVE-2025-32970?

Upgrade org.xwiki.platform:xwiki-platform-wysiwyg-api to a fixed version for your release line: 15.10.13, 16.4.4 or 16.8.0.

## Is CVE-2025-32970 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32970 exists.

Public exploit code:

- XWiki WYSIWYG API - Open Redirect (nuclei): http/cves/2025/CVE-2025-32970.yaml

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32970 and fix it if it is affected.

What it is: CVE-2025-32970 is a medium-severity vulnerability in Xwiki Xwiki, published on 30 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32970 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-wysiwyg-api (Maven): affected from 13.5-rc-1; fixed in 15.10.13
- org.xwiki.platform:xwiki-platform-wysiwyg-api (Maven): affected from 13.5-rc-1; fixed in 15.10.13
- org.xwiki.platform:xwiki-platform-wysiwyg-api (Maven): affected from 16.0.0-rc-1; fixed in 16.4.4
- org.xwiki.platform:xwiki-platform-wysiwyg-api (Maven): affected from 16.0.0-rc-1; fixed in 16.4.4
- org.xwiki.platform:xwiki-platform-wysiwyg-api (Maven): affected from 16.5.0-rc-1; fixed in 16.8.0
- org.xwiki.platform:xwiki-platform-wysiwyg-api (Maven): affected from 16.5.0-rc-1; fixed in 16.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32970/ (Markdown: https://insights.sbomify.com/CVE-2025-32970/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32970
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32970
- OSV: https://osv.dev/vulnerability/CVE-2025-32970

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32970/
Summaries are generated and may contain mistakes; the official description above is the record.
