# CVE-2025-32971: XWiki Solr script service doesn't take dropped programming right into account

> A user with script rights can bypass dropped programming permissions to cause high load or remove documents from the search index in XWiki.

- **Severity:** Low 3.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Apr 2025
- **Updated:** 30 Apr 2025
- **Also known as:** GHSA-987p-r3jc-8c8v

## What is CVE-2025-32971?

CVE-2025-32971 is a low-severity missing authorization vulnerability in Xwiki Xwiki, published on 30 Apr 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

XWiki is a generic wiki platform. In versions starting from 4.5.1 to before 15.10.13, from 16.0.0-rc-1 to before 16.4.4, and from 16.5.0-rc-1 to before 16.8.0-rc-1, the Solr script service doesn't take dropped programming rights into account. The Solr script service that is accessible in XWiki's scripting API normally requires programming rights to be called. Due to using the wrong API for checking rights, it doesn't take the fact into account that programming rights might have been dropped by calling `$xcontext.dropPermissions()`. If some code relies on this for the safety of executing Velocity code with the wrong author context, this could allow a user with script rights to either cause a high load by indexing documents or to temporarily remove documents from the search index. This issue has been patched in versions 15.10.13, 16.4.4, and 16.8.0-rc-1.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-32971?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-search-solr-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-search-solr-api` | Maven | From 16.0.0-rc-1 | 16.4.4 |
| `org.xwiki.platform:xwiki-platform-search-solr-api` | Maven | From 16.0.0-rc-1 | 16.4.4 |
| `org.xwiki.platform:xwiki-platform-search-solr-api` | Maven | From 16.5.0-rc-1 | 16.8.0-rc-1 |
| `org.xwiki.platform:xwiki-platform-search-solr-api` | Maven | From 16.5.0-rc-1 | 16.8.0-rc-1 |
| `org.xwiki.platform:xwiki-platform-search-solr-api` | Maven | From 4.5.1 | 15.10.13 |
| `org.xwiki.platform:xwiki-platform-search-solr-api` | Maven | From 4.5.1 | 15.10.13 |

Products: Xwiki Xwiki.

## How do I fix CVE-2025-32971?

Upgrade org.xwiki.platform:xwiki-platform-search-solr-api to a fixed version for your release line: 16.4.4, 16.8.0-rc-1 or 15.10.13.

## Is CVE-2025-32971 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32971 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32971 and fix it if it is affected.

What it is: CVE-2025-32971 is a low-severity missing authorization vulnerability in Xwiki Xwiki, published on 30 Apr 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32971 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-search-solr-api (Maven): affected from 16.0.0-rc-1; fixed in 16.4.4
- org.xwiki.platform:xwiki-platform-search-solr-api (Maven): affected from 16.0.0-rc-1; fixed in 16.4.4
- org.xwiki.platform:xwiki-platform-search-solr-api (Maven): affected from 16.5.0-rc-1; fixed in 16.8.0-rc-1
- org.xwiki.platform:xwiki-platform-search-solr-api (Maven): affected from 16.5.0-rc-1; fixed in 16.8.0-rc-1
- org.xwiki.platform:xwiki-platform-search-solr-api (Maven): affected from 4.5.1; fixed in 15.10.13
- org.xwiki.platform:xwiki-platform-search-solr-api (Maven): affected from 4.5.1; fixed in 15.10.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32971/ (Markdown: https://insights.sbomify.com/CVE-2025-32971/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32971
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32971
- OSV: https://osv.dev/vulnerability/CVE-2025-32971

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32971/
Summaries are generated and may contain mistakes; the official description above is the record.
