CVE-2025-32972 The lesscss script service allows cache clearing without programming right
Attackers with script rights can clear the LESS compiler cache without programming rights, causing performance degradation in XWiki.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-32972?
CVE-2025-32972 is a low-severity missing authorization vulnerability in Xwiki Xwiki, published on 30 Apr 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
XWiki is a generic wiki platform. In versions starting from 6.1-milestone-1 to before 15.10.12, from 16.0.0-rc-1 to before 16.4.3, and from 16.5.0-rc-1 to before 16.8.0-rc-1, the script API of the LESS compiler in XWiki is incorrectly checking for rights when calling the cache cleaning API, making it possible to clean the cache without having programming right. The only impact of this is a slowdown in XWiki execution as the caches are re-filled. As this vulnerability requires script right to exploit, and script right already allows unlimited execution of scripts, the additional impact due to this vulnerability is low. This issue has been patched in versions 15.10.12, 16.4.3, and 16.8.0-rc-1.
Weakness: CWE-285
Which versions are affected by CVE-2025-32972?
6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-lesscss-script. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-lesscss-script Maven | From 16.0.0-rc-1 | 16.4.3 |
org.xwiki.platform:xwiki-platform-lesscss-script Maven | From 16.0.0-rc-1 | 16.4.3 |
org.xwiki.platform:xwiki-platform-lesscss-script Maven | From 16.5.0-rc-1 | 16.8.0-rc-1 |
org.xwiki.platform:xwiki-platform-lesscss-script Maven | From 16.5.0-rc-1 | 16.8.0-rc-1 |
org.xwiki.platform:xwiki-platform-lesscss-script Maven | From 6.1-milestone-1 | 15.10.12 |
org.xwiki.platform:xwiki-platform-lesscss-script Maven | From 6.1-milestone-1 | 15.10.12 |
Products include Xwiki Xwiki.
How do I fix CVE-2025-32972?
Upgrade org.xwiki.platform:xwiki-platform-lesscss-script to a fixed version for your release line: 16.4.3, 16.8.0-rc-1 or 15.10.12.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-32972 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32972 exists.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-rp38-24m3-rx87.