# CVE-2025-32972: The lesscss script service allows cache clearing without programming right

> Attackers with script rights can clear the LESS compiler cache without programming rights, causing performance degradation in XWiki.

- **Severity:** Low 2.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Apr 2025
- **Updated:** 30 Apr 2025
- **Also known as:** GHSA-rp38-24m3-rx87

## What is CVE-2025-32972?

CVE-2025-32972 is a low-severity missing authorization vulnerability in Xwiki Xwiki, published on 30 Apr 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

XWiki is a generic wiki platform. In versions starting from 6.1-milestone-1 to before 15.10.12, from 16.0.0-rc-1 to before 16.4.3, and from 16.5.0-rc-1 to before 16.8.0-rc-1, the script API of the LESS compiler in XWiki is incorrectly checking for rights when calling the cache cleaning API, making it possible to clean the cache without having programming right. The only impact of this is a slowdown in XWiki execution as the caches are re-filled. As this vulnerability requires script right to exploit, and script right already allows unlimited execution of scripts, the additional impact due to this vulnerability is low. This issue has been patched in versions 15.10.12, 16.4.3, and 16.8.0-rc-1.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2025-32972?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-lesscss-script. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-lesscss-script` | Maven | From 16.0.0-rc-1 | 16.4.3 |
| `org.xwiki.platform:xwiki-platform-lesscss-script` | Maven | From 16.0.0-rc-1 | 16.4.3 |
| `org.xwiki.platform:xwiki-platform-lesscss-script` | Maven | From 16.5.0-rc-1 | 16.8.0-rc-1 |
| `org.xwiki.platform:xwiki-platform-lesscss-script` | Maven | From 16.5.0-rc-1 | 16.8.0-rc-1 |
| `org.xwiki.platform:xwiki-platform-lesscss-script` | Maven | From 6.1-milestone-1 | 15.10.12 |
| `org.xwiki.platform:xwiki-platform-lesscss-script` | Maven | From 6.1-milestone-1 | 15.10.12 |

Products: Xwiki Xwiki.

## How do I fix CVE-2025-32972?

Upgrade org.xwiki.platform:xwiki-platform-lesscss-script to a fixed version for your release line: 16.4.3, 16.8.0-rc-1 or 15.10.12.

## Is CVE-2025-32972 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32972 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32972 and fix it if it is affected.

What it is: CVE-2025-32972 is a low-severity missing authorization vulnerability in Xwiki Xwiki, published on 30 Apr 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32972 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-lesscss-script (Maven): affected from 16.0.0-rc-1; fixed in 16.4.3
- org.xwiki.platform:xwiki-platform-lesscss-script (Maven): affected from 16.0.0-rc-1; fixed in 16.4.3
- org.xwiki.platform:xwiki-platform-lesscss-script (Maven): affected from 16.5.0-rc-1; fixed in 16.8.0-rc-1
- org.xwiki.platform:xwiki-platform-lesscss-script (Maven): affected from 16.5.0-rc-1; fixed in 16.8.0-rc-1
- org.xwiki.platform:xwiki-platform-lesscss-script (Maven): affected from 6.1-milestone-1; fixed in 15.10.12
- org.xwiki.platform:xwiki-platform-lesscss-script (Maven): affected from 6.1-milestone-1; fixed in 15.10.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32972/ (Markdown: https://insights.sbomify.com/CVE-2025-32972/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32972
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32972
- OSV: https://osv.dev/vulnerability/CVE-2025-32972

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32972/
Summaries are generated and may contain mistakes; the official description above is the record.
