# CVE-2025-32973: org.xwiki.platform:xwiki-platform-component-wiki provides no warning when granting XWiki.ComponentClass programming right

> Attackers can trick admins into editing documents to gain programming rights, enabling code execution on the XWiki platform.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Apr 2025
- **Updated:** 30 Apr 2025
- **Also known as:** GHSA-x7wv-5qg4-vmr6

## What is CVE-2025-32973?

CVE-2025-32973 is a critical vulnerability in Xwiki Xwiki, published on 30 Apr 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

XWiki is a generic wiki platform. In versions starting from 15.9-rc-1 to before 15.10.12, from 16.0.0-rc-1 to before 16.4.3, and from 16.5.0-rc-1 to before 16.8.0-rc-1, when a user with programming rights edits a document in XWiki that was last edited by a user without programming rights and contains an XWiki.ComponentClass, there is no warning that this will grant programming rights to this object. An attacker who created such a malicious object could use this to gain programming rights on the wiki. For this, the attacker needs to have edit rights on at least one page to place this object and then get an admin user to edit that document. This issue has been patched in versions 15.10.12, 16.4.3, and 16.8.0-rc-1.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2025-32973?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-component-wiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-component-wiki` | Maven | From 15.9-rc-1 | 15.10.12 |
| `org.xwiki.platform:xwiki-platform-component-wiki` | Maven | From 15.9-rc-1 | 15.10.12 |
| `org.xwiki.platform:xwiki-platform-component-wiki` | Maven | From 16.0.0-rc-1 | 16.4.3 |
| `org.xwiki.platform:xwiki-platform-component-wiki` | Maven | From 16.0.0-rc-1 | 16.4.3 |
| `org.xwiki.platform:xwiki-platform-component-wiki` | Maven | From 16.5.0-rc-1 | 16.8.0-rc-1 |
| `org.xwiki.platform:xwiki-platform-component-wiki` | Maven | From 16.5.0-rc-1 | 16.8.0-rc-1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2025-32973?

Upgrade org.xwiki.platform:xwiki-platform-component-wiki to a fixed version for your release line: 15.10.12, 16.4.3 or 16.8.0-rc-1.

## Is CVE-2025-32973 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32973 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32973 and fix it if it is affected.

What it is: CVE-2025-32973 is a critical vulnerability in Xwiki Xwiki, published on 30 Apr 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32973 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-component-wiki (Maven): affected from 15.9-rc-1; fixed in 15.10.12
- org.xwiki.platform:xwiki-platform-component-wiki (Maven): affected from 15.9-rc-1; fixed in 15.10.12
- org.xwiki.platform:xwiki-platform-component-wiki (Maven): affected from 16.0.0-rc-1; fixed in 16.4.3
- org.xwiki.platform:xwiki-platform-component-wiki (Maven): affected from 16.0.0-rc-1; fixed in 16.4.3
- org.xwiki.platform:xwiki-platform-component-wiki (Maven): affected from 16.5.0-rc-1; fixed in 16.8.0-rc-1
- org.xwiki.platform:xwiki-platform-component-wiki (Maven): affected from 16.5.0-rc-1; fixed in 16.8.0-rc-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32973/ (Markdown: https://insights.sbomify.com/CVE-2025-32973/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32973
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32973
- OSV: https://osv.dev/vulnerability/CVE-2025-32973

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32973/
Summaries are generated and may contain mistakes; the official description above is the record.
