CVE-2025-32974 org.xwiki.platform:xwiki-platform-security-requiredrights-default required rights analysis doesn't consider TextAreas with default content type
Attackers can inject malicious scripts into TextAreas that execute with elevated privileges when edited by authorized users, compromising the wiki installation.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-32974?
CVE-2025-32974 is a critical vulnerability in Xwiki Xwiki, published on 30 Apr 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
XWiki is a generic wiki platform. In versions starting from 15.9-rc-1 to before 15.10.8 and from 16.0.0-rc-1 to before 16.2.0, the required rights analysis doesn't consider TextAreas with default content type. When editing a page, XWiki warns since version 15.9 when there is content on the page like a script macro that would gain more rights due to the editing. This analysis doesn't consider certain kinds of properties, allowing a user to put malicious scripts in there that will be executed after a user with script, admin, or programming rights edited the page. Such a malicious script could impact the confidentiality, integrity and availability of the whole XWiki installation. This issue has been patched in versions 15.10.8 and 16.2.0.
Which versions are affected by CVE-2025-32974?
4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-security-requiredrights-default. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-security-requiredrights-default Maven | From 15.9-rc-1 | 15.10.8 |
org.xwiki.platform:xwiki-platform-security-requiredrights-default Maven | From 15.9-rc-1 | 15.10.8 |
org.xwiki.platform:xwiki-platform-security-requiredrights-default Maven | From 16.0.0-rc-1 | 16.2.0 |
org.xwiki.platform:xwiki-platform-security-requiredrights-default Maven | From 16.0.0-rc-1 | 16.2.0 |
Products include Xwiki Xwiki.
How do I fix CVE-2025-32974?
Upgrade org.xwiki.platform:xwiki-platform-security-requiredrights-default to a fixed version for your release line: 15.10.8 or 16.2.0.
Is CVE-2025-32974 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32974 exists.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-mvgm-3rw2-7j4r.