# CVE-2025-32974: org.xwiki.platform:xwiki-platform-security-requiredrights-default required rights analysis doesn't consider TextAreas with default content type

> Attackers can inject malicious scripts into TextAreas that execute with elevated privileges when edited by authorized users, compromising the wiki installation.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Apr 2025
- **Updated:** 30 Apr 2025
- **Also known as:** GHSA-mvgm-3rw2-7j4r

## What is CVE-2025-32974?

CVE-2025-32974 is a critical vulnerability in Xwiki Xwiki, published on 30 Apr 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

XWiki is a generic wiki platform. In versions starting from 15.9-rc-1 to before 15.10.8 and from 16.0.0-rc-1 to before 16.2.0, the required rights analysis doesn't consider TextAreas with default content type. When editing a page, XWiki warns since version 15.9 when there is content on the page like a script macro that would gain more rights due to the editing. This analysis doesn't consider certain kinds of properties, allowing a user to put malicious scripts in there that will be executed after a user with script, admin, or programming rights edited the page. Such a malicious script could impact the confidentiality, integrity and availability of the whole XWiki installation. This issue has been patched in versions 15.10.8 and 16.2.0.

Weakness: CWE-269 (Improper Privilege Management), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2025-32974?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-security-requiredrights-default. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-security-requiredrights-default` | Maven | From 15.9-rc-1 | 15.10.8 |
| `org.xwiki.platform:xwiki-platform-security-requiredrights-default` | Maven | From 15.9-rc-1 | 15.10.8 |
| `org.xwiki.platform:xwiki-platform-security-requiredrights-default` | Maven | From 16.0.0-rc-1 | 16.2.0 |
| `org.xwiki.platform:xwiki-platform-security-requiredrights-default` | Maven | From 16.0.0-rc-1 | 16.2.0 |

Products: Xwiki Xwiki.

## How do I fix CVE-2025-32974?

Upgrade org.xwiki.platform:xwiki-platform-security-requiredrights-default to a fixed version for your release line: 15.10.8 or 16.2.0.

## Is CVE-2025-32974 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32974 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32974 and fix it if it is affected.

What it is: CVE-2025-32974 is a critical vulnerability in Xwiki Xwiki, published on 30 Apr 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32974 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-security-requiredrights-default (Maven): affected from 15.9-rc-1; fixed in 15.10.8
- org.xwiki.platform:xwiki-platform-security-requiredrights-default (Maven): affected from 15.9-rc-1; fixed in 15.10.8
- org.xwiki.platform:xwiki-platform-security-requiredrights-default (Maven): affected from 16.0.0-rc-1; fixed in 16.2.0
- org.xwiki.platform:xwiki-platform-security-requiredrights-default (Maven): affected from 16.0.0-rc-1; fixed in 16.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32974/ (Markdown: https://insights.sbomify.com/CVE-2025-32974/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32974
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32974
- OSV: https://osv.dev/vulnerability/CVE-2025-32974

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32974/
Summaries are generated and may contain mistakes; the official description above is the record.
