# CVE-2025-33042: Apache Avro Java SDK: Code injection on Java generated code

> Attackers can execute arbitrary code by providing malicious Avro schemas to the Apache Avro Java SDK during record generation.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Feb 2026
- **Updated:** 13 Feb 2026
- **Also known as:** CLEANSTART-2026-YI17709, CLSA-2026-1786540164, CLSA-2026-1786540569, CLSA-2026-1786540745, CLSA-2026-1792063230, CLSA-2026-1792063313, GHSA-rp46-r563-jrc7, JLSEC-2026-1375, MINI-39c6-cxv8-xmr3, MINI-58cw-367h-4qj6, MINI-9gj9-2qc2-5c6f, MINI-fw5w-mp54-3fmh, MINI-j65r-jwv7-pwpv, MINI-jmgh-7c7m-vxx5, MINI-p5w5-jh88-gppc, MINI-p8xm-p67m-j8wp, MINI-q2hr-4p4r-8cvp, MINI-qc9w-g2mw-x34f, MINI-w6f9-xmcv-pmv5, PYSEC-2026-26, RHLW-2026-9fa472b9239a3a7e

## What is CVE-2025-33042?

CVE-2025-33042 is a high-severity code injection vulnerability in Apache Avro Java SDK, published on 13 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Avro Java SDK when generating specific records from untrusted Avro schemas.

This issue affects Apache Avro Java SDK: all versions through 1.11.4 and version 1.12.0.

Users are recommended to upgrade to version 1.12.1 or 1.11.5, which fix the issue.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2025-33042?

5 open source packages ship an affected version, including org.apache.avro:avro-compiler and avro. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.avro:avro-compiler` | Maven | All versions | 1.11.5 |
| `org.apache.avro:avro-compiler` | Maven | All versions | 1.11.5 |
| `org.apache.avro:avro-compiler` | Maven | From 1.12.0 | 1.12.1 |
| `org.apache.avro:avro-compiler` | Maven | From 1.12.0 | 1.12.1 |
| `avro` | PyPI | All versions | 1.11.5 |

Products: Apache Avro.

## How do I fix CVE-2025-33042?

Upgrade org.apache.avro:avro-compiler to a fixed version for your release line: 1.11.5 or 1.12.1.

## Is CVE-2025-33042 being exploited?

There is no known exploitation of CVE-2025-33042 in the wild and no public exploit code.

## Other vulnerabilities in Apache Avro Java SDK

- [CVE-2024-47561](https://insights.sbomify.com/CVE-2024-47561/): Apache Avro Java SDK: Arbitrary Code Execution when reading Avro schema (Java SDK) (critical 9.2)
- [CVE-2023-39410](https://insights.sbomify.com/CVE-2023-39410/): Apache Avro Java SDK: Memory when deserializing untrusted data in Avro Java SDK (high 7.5)
- [CVE-2022-35724](https://insights.sbomify.com/CVE-2022-35724/): Denial of service while reading data in Avro Rust SDK (high 7.5)
- [CVE-2022-36124](https://insights.sbomify.com/CVE-2022-36124/): Memory overconsumption in Avro Rust SDK (high 7.5)
- [CVE-2022-36125](https://insights.sbomify.com/CVE-2022-36125/): Integer overflow when reading corrupted .avro file in Avro Rust SDK (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-33042 and fix it if it is affected.

What it is: CVE-2025-33042 is a high-severity code injection vulnerability in Apache Avro Java SDK, published on 13 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-33042 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.avro:avro-compiler (Maven): affected all versions; fixed in 1.11.5
- org.apache.avro:avro-compiler (Maven): affected all versions; fixed in 1.11.5
- org.apache.avro:avro-compiler (Maven): affected from 1.12.0; fixed in 1.12.1
- org.apache.avro:avro-compiler (Maven): affected from 1.12.0; fixed in 1.12.1
- avro (PyPI): affected all versions; fixed in 1.11.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-33042/ (Markdown: https://insights.sbomify.com/CVE-2025-33042/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-33042
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-33042
- OSV: https://osv.dev/vulnerability/CVE-2025-33042

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-33042/
Summaries are generated and may contain mistakes; the official description above is the record.
