{"answers":{"affected":"3 open source packages ship an affected version, including nemo-toolkit. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-33245 in the wild and no public exploit code.","fix":"Upgrade nemo-toolkit to 2.6.1 or later.","what":"CVE-2025-33245 is a high-severity unsafe deserialization vulnerability in NVIDIA NeMo Framework, published on 18 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-33245 and fix it if it is affected.\n\nWhat it is: CVE-2025-33245 is a high-severity unsafe deserialization vulnerability in NVIDIA NeMo Framework, published on 18 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-33245 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nemo-toolkit (PyPI): affected all versions; fixed in 2.6.1\n- nemo-toolkit (PyPI): affected all versions; fixed in 2.6.1\n- nemo-toolkit (PyPI): affected all versions; fixed in 2.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-33245/ (Markdown: https://insights.sbomify.com/CVE-2025-33245/index.md)","id":"CVE-2025-33245","markdown":"https://insights.sbomify.com/CVE-2025-33245/index.md","name":"CVE-2025-33245","record":{"aliases":["GHSA-9379-mwvr-7wxx","PYSEC-2026-2672"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution","privilege_escalation","data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"NVIDIA NeMo Framework","requires_auth":"low_privilege","summary":"Attackers can achieve remote code execution and privilege escalation via malicious data in NVIDIA NeMo Framework.","user_interaction":"required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"nvidia","cpe":[{"product":"nemo","vendor":"nvidia"}],"cvss":{"score":8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"NVIDIA NeMo Framework contains a vulnerability where malicious data could cause remote code execution. A successful exploit of this vulnerability might lead to code execution, escalation of privileges, information disclosure, and data tampering.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"NVIDIA NeMo Framework contains a vulnerability where malicious data could cause remote code execution","id":"CVE-2025-33245","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2025"},"n_packages":3,"n_references":3,"next":{"headline":"Command injection in NeMo Framework","id":"CVE-2025-33246"},"packages":[{"ecosystem":"PyPI","fixed":["2.6.1"],"introduced":["0"],"last_affected":[],"package":"nemo-toolkit","purl":null,"source":"GHSA-9379-mwvr-7wxx"},{"ecosystem":"PyPI","fixed":["2.6.1"],"introduced":["0"],"last_affected":[],"package":"nemo-toolkit","purl":"pkg:pypi/nemo-toolkit","source":"GHSA-9379-mwvr-7wxx"},{"ecosystem":"PyPI","fixed":["2.6.1"],"introduced":["0"],"last_affected":[],"package":"nemo-toolkit","purl":"pkg:pypi/nemo-toolkit","source":"PYSEC-2026-2672"}],"prev":{"headline":"Deserialization in Apex","id":"CVE-2025-33244"},"products":["NeMo Framework"],"published":"2026-02-18","related":[{"cvss_score":8.6,"headline":"Denial of service in NeMo","id":"CVE-2024-0081","kev_date_added":null,"published":"2024-04-05"},{"cvss_score":7.8,"headline":"Command injection in NeMo Framework","id":"CVE-2026-24252","kev_date_added":null,"published":"2026-07-27"},{"cvss_score":7.8,"headline":"Code injection in NeMo Framework","id":"CVE-2026-24155","kev_date_added":null,"published":"2026-06-16"},{"cvss_score":7.8,"headline":"Deserialization in NeMo Framework","id":"CVE-2026-24228","kev_date_added":null,"published":"2026-06-16"},{"cvss_score":7.8,"headline":"NVIDIA NeMo Framework contains an RCE vulnerability in checkpoint loading","id":"CVE-2026-24157","kev_date_added":null,"published":"2026-03-24"},{"cvss_score":7.8,"headline":"NVIDIA NeMo Framework contains a vulnerability leading to Remote Code Execution","id":"CVE-2026-24159","kev_date_added":null,"published":"2026-03-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-02-26","vendors":["NVIDIA"]},"summary":"Attackers can achieve remote code execution and privilege escalation via malicious data in NVIDIA NeMo Framework.","url":"https://insights.sbomify.com/CVE-2025-33245/"}