CVE-2025-34115 OP5 Monitor <= 7.1.9 Authenticated Command Execution via command_test.php

High 8.7 Published Updated

Authenticated attackers can execute arbitrary shell commands via the command_test.php endpoint in OP5 Monitor.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-34115?

CVE-2025-34115 is a high-severity command injection vulnerability in ITRS Group OP5 Monitor, published on 15 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An authenticated command injection vulnerability exists in OP5 Monitor through version 7.1.9 via the 'cmd_str' parameter in the command_test.php endpoint. A user with access to the web interface can exploit the 'Test this command' feature to execute arbitrary shell commands as the unprivileged web application user. The vulnerability resides in the configuration section of the application and requires valid login credentials with access to the command testing functionality. This issue is fixed in version 7.2.0.

Weakness: CWE-78, CWE-306, CWE-20

Which versions are affected by CVE-2025-34115?

How do I fix CVE-2025-34115?

No fix has been published for CVE-2025-34115 yet. Limit exposure of the affected software until one is available.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2025-34115 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-34115 exists.

Public exploit code: 1 Metasploit module.

Sources

Also known as GHSA-gv2v-p8xm-xh87.

Is CVE-2025-34115 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free