{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-34115 exists.","fix":"No fix has been published for CVE-2025-34115 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-34115 is a high-severity command injection vulnerability in ITRS Group OP5 Monitor, published on 15 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-34115 and fix it if it is affected.\n\nWhat it is: CVE-2025-34115 is a high-severity command injection vulnerability in ITRS Group OP5 Monitor, published on 15 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-34115 exists.\n\nAffected product: ITRS Group OP5 Monitor. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-34115/ (Markdown: https://insights.sbomify.com/CVE-2025-34115/index.md)","id":"CVE-2025-34115","markdown":"https://insights.sbomify.com/CVE-2025-34115/index.md","name":"CVE-2025-34115","record":{"aliases":["GHSA-gv2v-p8xm-xh87"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"IT monitoring software","requires_auth":"low_privilege","summary":"Authenticated attackers can execute arbitrary shell commands via the command_test.php endpoint in OP5 Monitor.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"},{"id":"CWE-306","name":"Missing Authentication for Critical Functionality"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"An authenticated command injection vulnerability exists in OP5 Monitor through version 7.1.9 via the 'cmd_str' parameter in the command_test.php endpoint. A user with access to the web interface can exploit the 'Test this command' feature to execute arbitrary shell commands as the unprivileged web application user. The vulnerability resides in the configuration section of the application and requires valid login credentials with access to the command testing functionality. This issue is fixed in version 7.2.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":"2016-04-08","github_poc":0,"max_poc_stars":null,"metasploit":1,"nuclei":0,"refs":[{"date":"2016-04-08","kind":"metasploit","ref":"exploit/linux/http/op5_config_exec","stars":null,"title":"op5 v7.1.9 Configuration Command Execution"}],"tier":"weaponised"},"has_fix":null,"headline":"OP5 Monitor \u003c= 7.1.9 Authenticated Command Execution via command_test.php","id":"CVE-2025-34115","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":0,"n_references":4,"next":{"headline":"IPFire \u003c 2.19 Core Update 101 proxy.cgi RCE","id":"CVE-2025-34116"},"packages":[],"prev":{"headline":"OpenBlow Missing Critical Security Headers","id":"CVE-2025-34114"},"products":["OP5 Monitor"],"published":"2025-07-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-08","vendors":["ITRS Group"]},"summary":"Authenticated attackers can execute arbitrary shell commands via the command_test.php endpoint in OP5 Monitor.","url":"https://insights.sbomify.com/CVE-2025-34115/"}