# CVE-2025-34146: nyariv sandboxjs 0.8.23 Prototype Pollution Sandbox Escape DoS

> Attackers can escape the sandbox and execute arbitrary code or cause denial of service via prototype pollution in the sandboxjs library.

- **Severity:** High 7.0 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jul 2025
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-9qm3-6qrr-c76m

## What is CVE-2025-34146?

CVE-2025-34146 is a high-severity code injection vulnerability in nyariv sandboxjs, published on 31 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A prototype pollution vulnerability exists in @nyariv/sandboxjs versions <= 0.8.23, allowing attackers to inject arbitrary properties into Object.prototype via crafted JavaScript code. This can result in a denial-of-service (DoS) condition or, under certain conditions, escape the sandboxed environment intended to restrict code execution. The vulnerability stems from insufficient prototype access checks in the sandbox’s executor logic, particularly in the handling of JavaScript function objects returned.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2025-34146?

2 open source packages ship an affected version, including @nyariv/sandboxjs.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@nyariv/sandboxjs` | npm | All versions | 0.8.24 |
| `@nyariv/sandboxjs` | npm | All versions | 0.8.24 |

## How do I fix CVE-2025-34146?

Upgrade @nyariv/sandboxjs to 0.8.24 or later.

## Is CVE-2025-34146 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-34146 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-34146 and fix it if it is affected.

What it is: CVE-2025-34146 is a high-severity code injection vulnerability in nyariv sandboxjs, published on 31 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-34146 exists.

Affected packages and fixed versions:
- @nyariv/sandboxjs (npm): affected all versions; fixed in 0.8.24
- @nyariv/sandboxjs (npm): affected all versions; fixed in 0.8.24

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-34146/ (Markdown: https://insights.sbomify.com/CVE-2025-34146/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-34146
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-34146
- OSV: https://osv.dev/vulnerability/CVE-2025-34146

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-34146/
Summaries are generated and may contain mistakes; the official description above is the record.
