CVE-2025-34267 Flowise Authenticated Command Execution and Sandbox Bypass via Puppeteer & Playwright Packages
Authenticated attackers can execute arbitrary code on the host by bypassing sandbox restrictions via Puppeteer or Playwright when built-in dependencies are enabled.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-34267?
CVE-2025-34267 is a high-severity command injection vulnerability in Flowiseai Flowise, published on 14 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Flowise v3.0.1 < 3.0.8 and all versions after with 'ALLOW_BUILTIN_DEP' enabled contain an authenticated remote code execution vulnerability and node VM sandbox escape due to insecure use of integrated modules (Puppeteer and Playwright) within the nodevm execution environment. An authenticated attacker able to create or run a tool that leverages Puppeteer/Playwright can specify attacker-controlled browser binary paths and parameters. When the tool executes, the attacker-controlled executable/parameters are run on the host and circumvent the intended nodevm sandbox restrictions, resulting in execution of arbitrary code in the context of the host. This vulnerability was incorrectly assigned as a duplicate CVE-2025-26319 by the developers and should be considered distinct from that identifier.
Weakness: CWE-77
Which versions are affected by CVE-2025-34267?
2 open source packages ship an affected version, including flowise. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
flowise npm | From 3.0.1 | 3.0.8 |
flowise npm | From 3.0.1 | 3.0.8 |
Products include Flowiseai Flowise.
How do I fix CVE-2025-34267?
Upgrade flowise to 3.0.8 or later.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2025-34267 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-34267 exists.
Other vulnerabilities in Flowiseai Flowise
- CVE-2025-71338 Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API
- CVE-2026-40933 Flowise: Authenticated RCE Via MCP Adapters
- CVE-2025-61913 Flowise is vulnerable to arbitrary file read, arbitrary file write
- CVE-2025-59528 Flowise has Remote Code Execution vulnerability
- CVE-2026-52098 Code injection in n/a
Sources
Also known as GHSA-5w3r-f6gm-c25w, GHSA-r4hh-pcgx-j5r2.