{"answers":{"affected":"2 open source packages ship an affected version, including flowise. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-34267 exists.","fix":"Upgrade flowise to 3.0.8 or later.","what":"CVE-2025-34267 is a high-severity command injection vulnerability in Flowiseai Flowise, published on 14 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-34267 and fix it if it is affected.\n\nWhat it is: CVE-2025-34267 is a high-severity command injection vulnerability in Flowiseai Flowise, published on 14 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-34267 exists.\n\nAffected packages and fixed versions:\n- flowise (npm): affected from 3.0.1; fixed in 3.0.8\n- flowise (npm): affected from 3.0.1; fixed in 3.0.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-34267/ (Markdown: https://insights.sbomify.com/CVE-2025-34267/index.md)","id":"CVE-2025-34267","markdown":"https://insights.sbomify.com/CVE-2025-34267/index.md","name":"CVE-2025-34267","record":{"aliases":["GHSA-5w3r-f6gm-c25w","GHSA-r4hh-pcgx-j5r2"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Flowise AI platform","requires_auth":"high_privilege","summary":"Authenticated attackers can execute arbitrary code on the host by bypassing sandbox restrictions via Puppeteer or Playwright when built-in dependencies are enabled.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[{"product":"flowise","vendor":"flowiseai"}],"cvss":{"score":8.4,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:L/VA:L/SC:H/SI:H/SA:L","version":"4.0"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"Flowise v3.0.1 \u003c 3.0.8 and all versions after with 'ALLOW_BUILTIN_DEP' enabled contain an authenticated remote code execution vulnerability and node VM sandbox escape due to insecure use of integrated modules (Puppeteer and Playwright) within the nodevm execution environment. An authenticated attacker able to create or run a tool that leverages Puppeteer/Playwright can specify attacker-controlled browser binary paths and parameters. When the tool executes, the attacker-controlled executable/parameters are run on the host and circumvent the intended nodevm sandbox restrictions, resulting in execution of arbitrary code in the context of the host. This vulnerability was incorrectly assigned as a duplicate CVE-2025-26319 by the developers and should be considered distinct from that identifier.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Flowise Authenticated Command Execution and Sandbox Bypass via Puppeteer \u0026 Playwright Packages","id":"CVE-2025-34267","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"flowiseai:flowise","products":["flowiseai:flowise"],"type":"command_injection","year":"2025"},"n_packages":2,"n_references":4,"next":{"headline":"This CVE ID was rejected because it was reserved but not used for a vulnerability disclosure.","id":"CVE-2025-34268"},"packages":[{"ecosystem":"npm","fixed":["3.0.8"],"introduced":["3.0.1"],"last_affected":[],"package":"flowise","purl":null,"source":"GHSA-r4hh-pcgx-j5r2"},{"ecosystem":"npm","fixed":["3.0.8"],"introduced":["3.0.1"],"last_affected":[],"package":"flowise","purl":"pkg:npm/flowise","source":"GHSA-r4hh-pcgx-j5r2"}],"prev":{"headline":"Advantech WISE-DeviceOn Server \u003c 5.4 Authenticated Stored XSS via plugin-config/addins/menus","id":"CVE-2025-34266"},"products":["Flowise"],"published":"2025-10-14","related":[{"cvss_score":10,"headline":"Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API","id":"CVE-2025-71338","kev_date_added":null,"published":"2026-06-25"},{"cvss_score":10,"headline":"Flowise: Authenticated RCE Via MCP Adapters","id":"CVE-2026-40933","kev_date_added":null,"published":"2026-04-21"},{"cvss_score":10,"headline":"Flowise is vulnerable to arbitrary file read, arbitrary file write","id":"CVE-2025-61913","kev_date_added":null,"published":"2025-10-08"},{"cvss_score":10,"headline":"Flowise has Remote Code Execution vulnerability","id":"CVE-2025-59528","kev_date_added":null,"published":"2025-09-22"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2026-52098","kev_date_added":null,"published":"2026-09-10"},{"cvss_score":9.8,"headline":"Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover","id":"CVE-2025-58434","kev_date_added":null,"published":"2025-09-12"},{"cvss_score":9.8,"headline":"Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers","id":"CVE-2025-8943","kev_date_added":null,"published":"2025-08-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["FlowiseAI"]},"summary":"Authenticated attackers can execute arbitrary code on the host by bypassing sandbox restrictions via Puppeteer or Playwright when built-in dependencies are enabled.","url":"https://insights.sbomify.com/CVE-2025-34267/"}