# CVE-2025-34267: Flowise Authenticated Command Execution and Sandbox Bypass via Puppeteer & Playwright Packages

> Authenticated attackers can execute arbitrary code on the host by bypassing sandbox restrictions via Puppeteer or Playwright when built-in dependencies are enabled.

- **Severity:** High 8.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:L/VA:L/SC:H/SI:H/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2025
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-5w3r-f6gm-c25w, GHSA-r4hh-pcgx-j5r2

## What is CVE-2025-34267?

CVE-2025-34267 is a high-severity command injection vulnerability in Flowiseai Flowise, published on 14 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Flowise v3.0.1 < 3.0.8 and all versions after with 'ALLOW_BUILTIN_DEP' enabled contain an authenticated remote code execution vulnerability and node VM sandbox escape due to insecure use of integrated modules (Puppeteer and Playwright) within the nodevm execution environment. An authenticated attacker able to create or run a tool that leverages Puppeteer/Playwright can specify attacker-controlled browser binary paths and parameters. When the tool executes, the attacker-controlled executable/parameters are run on the host and circumvent the intended nodevm sandbox restrictions, resulting in execution of arbitrary code in the context of the host. This vulnerability was incorrectly assigned as a duplicate CVE-2025-26319 by the developers and should be considered distinct from that identifier.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2025-34267?

2 open source packages ship an affected version, including flowise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | From 3.0.1 | 3.0.8 |
| `flowise` | npm | From 3.0.1 | 3.0.8 |

Products: Flowiseai Flowise.

## How do I fix CVE-2025-34267?

Upgrade flowise to 3.0.8 or later.

## Is CVE-2025-34267 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-34267 exists.

## Other vulnerabilities in Flowiseai Flowise

- [CVE-2025-71338](https://insights.sbomify.com/CVE-2025-71338/): Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API (critical 10.0)
- [CVE-2026-40933](https://insights.sbomify.com/CVE-2026-40933/): Flowise: Authenticated RCE Via MCP Adapters (critical 10.0)
- [CVE-2025-61913](https://insights.sbomify.com/CVE-2025-61913/): Flowise is vulnerable to arbitrary file read, arbitrary file write (critical 10.0)
- [CVE-2025-59528](https://insights.sbomify.com/CVE-2025-59528/): Flowise has Remote Code Execution vulnerability (critical 10.0)
- [CVE-2026-52098](https://insights.sbomify.com/CVE-2026-52098/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-34267 and fix it if it is affected.

What it is: CVE-2025-34267 is a high-severity command injection vulnerability in Flowiseai Flowise, published on 14 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-34267 exists.

Affected packages and fixed versions:
- flowise (npm): affected from 3.0.1; fixed in 3.0.8
- flowise (npm): affected from 3.0.1; fixed in 3.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-34267/ (Markdown: https://insights.sbomify.com/CVE-2025-34267/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-34267
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-34267
- OSV: https://osv.dev/vulnerability/CVE-2025-34267

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-34267/
Summaries are generated and may contain mistakes; the official description above is the record.
