# CVE-2025-34281: Stored Cross-Site Scripting (XSS) in ThingsBoard

> Authenticated users can upload malicious SVGs to trigger stored XSS, potentially compromising other users' accounts and sessions.

- **Severity:** Medium 6.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Oct 2025
- **Updated:** 10 Feb 2026
- **Also known as:** GHSA-fpq4-r87v-g246

## What is CVE-2025-34281?

CVE-2025-34281 is a medium-severity cross-site scripting vulnerability in thingsboard, published on 17 Oct 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

ThingsBoard in versions prior to v4.2.1 allows an authenticated user to upload malicious SVG images via the "Image Gallery", leading to a Stored Cross-Site Scripting (XSS) vulnerability. The exploit can be triggered when any user accesses the public API endpoint of the malicious SVG images, or if the malicious images are embedded in an `iframe` element, during a widget creation, deployed to any page of the platform (e.g., dashboards), and accessed during normal operations. The vulnerability resides in the `ImageController`, which fails to restrict the execution of JavaScript code when an image is loaded by the user's browser. This vulnerability can lead to the execution of malicious code in the context of other users' sessions, potentially compromising their accounts and allowing unauthorized actions.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-34281?

2 open source packages ship an affected version, including org.thingsboard:application. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.thingsboard:application` | Maven | All versions | 4.2.1 |
| `org.thingsboard:application` | Maven | All versions | 4.2.1 |

Products: Thingsboard Thingsboard.

## How do I fix CVE-2025-34281?

Upgrade org.thingsboard:application to 4.2.1 or later.

## Is CVE-2025-34281 being exploited?

There is no known exploitation of CVE-2025-34281 in the wild and no public exploit code.

## Other vulnerabilities in thingsboard

- [CVE-2022-40004](https://insights.sbomify.com/CVE-2022-40004/): Cross-site scripting in n/a (critical 9.6)
- [CVE-2022-45608](https://insights.sbomify.com/CVE-2022-45608/): Privilege escalation in n/a (high 8.8)
- [CVE-2022-48341](https://insights.sbomify.com/CVE-2022-48341/): Privilege escalation in n/a (high 8.8)
- [CVE-2020-27687](https://insights.sbomify.com/CVE-2020-27687/): Open redirect in n/a (high 8.8)
- [CVE-2023-45303](https://insights.sbomify.com/CVE-2023-45303/): ThingsBoard Server-Side Template Injection (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-34281 and fix it if it is affected.

What it is: CVE-2025-34281 is a medium-severity cross-site scripting vulnerability in thingsboard, published on 17 Oct 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-34281 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.thingsboard:application (Maven): affected all versions; fixed in 4.2.1
- org.thingsboard:application (Maven): affected all versions; fixed in 4.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-34281/ (Markdown: https://insights.sbomify.com/CVE-2025-34281/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-34281
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-34281
- OSV: https://osv.dev/vulnerability/CVE-2025-34281

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-34281/
Summaries are generated and may contain mistakes; the official description above is the record.
