CVE-2025-3438 MStore API – Create Native Android & iOS Apps On The Cloud <= 4.17.4 - Unauthenticated Limited Privilege Escalation

Medium 6.5 Published Updated

Unauthenticated attackers can register with vendor privileges if the WCFM Marketplace plugin is active, enabling limited privilege escalation.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-3438?

CVE-2025-3438 is a medium-severity vulnerability in inspireui MStore API – Create Native Android & iOS Apps On The Cloud, published on 2 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The MStore API – Create Native Android & iOS Apps On The Cloud plugin for WordPress is vulnerable to limited privilege escalation in all versions up to, and including, 4.17.4. This is due to a lack of restriction of role when registering. This makes it possible for unauthenticated attackers to to register with the 'wcfm_vendor' role, which is a Store Vendor role in the WCFM Marketplace – Multivendor Marketplace for WooCommerce plugin for WordPress. The vulnerability can only be exploited if the WCFM Marketplace – Multivendor Marketplace for WooCommerce plugin is installed and activated. The vulnerability was partially patched in version 4.17.3.

Weakness: CWE-269

Which versions are affected by CVE-2025-3438?

It affects 1 product.

Products include Inspireui Mstore Api.

How do I fix CVE-2025-3438?

No fix has been published for CVE-2025-3438 yet. Limit exposure of the affected software until one is available.

Is CVE-2025-3438 being exploited?

There is no known exploitation of CVE-2025-3438 in the wild and no public exploit code.

Sources

Also known as GHSA-f367-gfrg-qv3c.

Is CVE-2025-3438 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free